Pimax 8kx USB port issue

Hi there, just changed my motherboard ( msi Z390 changed with msi Z590) and I have a USB port issue since. Each and every time I turn off my PC I have to unplug and replug theHMD usb connector to make it work. If I don’t do that my 8kx is off, no front light, no led.
I have latest pitool and dfu (273,299) Windows 10 and Nvidia driver up to date.
Any help would be much appreciated, thanks

1 Like

Sorry, i can’t help with you, but just posting to say I too have to disconnect my 8kx’s usb then reconnect after my pc has been turned off and on in order for my 8kx to work. I just thought it was a little quirk of the headset.

1 Like

Not sure if it’ll do anything in Your case, but I have USB standby power enabled in BIOS which means my 8KX never “powers off” so I have to enter/exit standby on it by long-pressing the power button on the headset, regardless of whether my PC is on or off.

6 Likes

Ah right ok, ive just checked my bios and alas could not find any usb setting like that (asus z270-k prime). It might help op though.

2 Likes

https://www.asus.com/support/FAQ/1042220/

USB power delivery in Soft Off State (S5)

Has to be enabled (guide is about the opposite)

7 Likes

Hey thank you for that :slightly_smiling_face:! When i’m at my computer later i will change that setting.

4 Likes

Just remember You now have to put the headset into standby manually (long-press till the LED is bright red)… :slightly_smiling_face:

… And it will stay there until manually powered on… :wink:

3 Likes

me too, and it got worse when I got the fiber optic cable, as now It only stays connected on “certain” USB ports.

2 Likes

I got tired of dealing with standby mode (which would sometimes exit the mode upon PC reboot). It’s difficult to reach the back of my PC (under my desk) to unplug the USB cable, so I got one of these USB switched cables. I like it a lot.

2 Likes

I’ve never had that happen (knock on wood) but that’s a fine solution… :slightly_smiling_face:

I’m using an in-line switch for one of my lighthouses (mounted over my monitor/desk for seated sessions).

2 Likes

Unfortunately, before I realized what was happening, I would discover that my 8KX had been fully on for hours, perhaps even a day or more. I rarely turn my main PC off, but I do have to reboot it occasionally. Later, I would notice the blinking chevron, pick up the headset to put it back into standby mode, and notice it was almost hot to the touch.

I have my base station on a remote power switch, because I don’t have the free time to play in VR as much as I’d like (it’s usually several days between sessions) and I don’t want to leave the equipment on all the time.

2 Likes

Works great, thanks mate

3 Likes