Pimax 8KX - Why no sound?

Sorry my English. It’s not my native language.

On this last February I bought what I think to be the latest version of Pimax 8KX (mine only works at 90Hz) and I have a problem with the sound. I just don’t have sound in the Pimax 8KX headphones!

I think it’s a software problem, because if I install a VR program, such as The Blue, the sound works perfectly. However, if I later exit Pitool or if I turn off the computer, when I re-enter Pitool, I no longer have sound through the headphones of the Pimax 8K. To ear anything, at that point, I have to select the sound output as being the speakers I have connected to my computer motherboard. To get sound again through the Pimax 8KX, I need to uninstall The Blue and reinstall it.

My computer is an i7-12700K, on an Asus TUF Gaming Z690-Plus D4 motherboard, and the graphics card is an MSI RTX 3090 Gaming Trio X. Windows is version 11. I have already reinstalled Windows 11, reinstalled Pitool and Steam VR and I can not find a way to solve this problem. And I have also reinstalled the Nvidia driver (I’m always using the last version of Nvidia drivers), because Windows 11 says that the audio driver is the Pimax 2PNA (Nvidia High Definition Audio), but without success.

Anyone with the same problem?

1 Like

The new version you need to goto Windows Sound settings and switch it to 5.1/7.1 from what has been said.

I have read this, but the fact is that at least Windows 11 does not allow me to choose 5.1/7.1 sound to the Pimax 8KX. Just stereo or Windows Sonic for Headphones.

1 Like

Try the sound settings in Steam VR: set to headset.

1 Like

There are two speakers (left + right) so why would 5.1/7.1 be an option or even be wanted?

As Darrell says, try to set the output device in SteamVR.

The sound is set, in the SteamVR, to the headset.

It’s like something in Windows just cancel the sound through the Pimax 8KX after I shutdown the computer.

At first, there were several times when the sound still worked, even after turning the computer off and on again (I usually turn the computer eletric power off), but now, when I manage to get the sound to work (like after install again The Blue), after the first computer shutdown, Windows 11, somehow, blocks the sound. Interestingly, if I do the Windows sound test, the graphs show that signal is being output to the helmet speakers, but no sound is coming out.

1 Like

I see. That sounds (no pun intended) really odd… :roll_eyes:

pffffffffffffffffffffffffffffffffffffff like me

The revised 8kX uses a different Audio chip in this version it has been said to change Audio setting to 5.1/7.1 to get sound.

Link below.

1 Like

Hello HuDz:
Sorry for the bad experience.
You may firest try the guide of community,if it doesnit work,we suggest you to submit ticket and allows our technician to diagnose it.
Regards.

Sounds like a driver bug/quirk to me… :relaxed:

If it has to be set to 5.1/7.1 why are other options offered?

1 Like

Not sure to be honest. It is one of a few complaints with the Revised 8kX. There is a compare between the 2 8kX versions on r/pimax. Other than the 90hz being stable for Nvidia Desktop RTX cards(only gpus compatible) and that the 8kX hum not being present that a few ppl experienced. It seems that the compare at this time that the revised model needs time to mature compared to the older version.

1 Like

Not HuDz, but instead brown66.

I just finished filling and send the ticked. I was afraid you’d tell me to this. It will be hard to get back to my old HTC Vive Pro, if I have to return this Pimax 8KX. I was hoping it was some kind of problem that I could solve in my house with a firmware update.

1 Like

By Technician @hammerhead_gal I believe is initially referring to setting up a time to do a remote access session to take a look.

Often they can resolve an issue without an RMA.

1 Like

I hope so!

Cross fingers…

1 Like

It seems that I have already found the root of the problem - the driver for the Realtek Audio was not updated. I updated it and now the sound through Pimax 8kX works whenever I need it. Fingers crossed so it stays that way.

Anyway, thanks for your support!

3 Likes

Awesome to hear! Enjoy. :beers::sunglasses::vulcan_salute::sparkles:

1 Like