Pimax artisan purple led light!

Hello
my pimax artisan not working after try to ubdate firmware i got led light purple and i got massage not recognize usb.try to unplug power and connect power no red red light only purple colour for pimax
artisan what can i do?

I would file a support Ticket. The purple led should only mean Parallel Projection mode is on.

Do you have another pc that you can test on? It needn’t be strong enough to play on.

yes i tested with another pc same thing just only purple led no usb recognize from pc

Have you file a support ticket?

Yes i file support aticket

1 Like

Hello,

The purple colour indicator which means the PP mode is on.
You may provide us the ticket number, so we can forward it to tech team, and ask them response on the ticket.

1 Like

ticket number
#16277
#16305

1 Like

Hello,

We spoke with tech team, someone is following your case.
If they didn’t response for consecutive 48hours, please let us know.

1 Like

Hello
yes i got it its worked the the red light back again the purple gone away :grinning:

but still not connect ,i use laptop no display port native but i use adapter from usb c type to display port
i got massage diagnose 1600 Dp no connection, i will try to use another pc i hope get green led soon :slightly_smiling_face:

2 Likes

This is almost certainly the cause of your issue. It seems your converter is not fully converting the signal. Some of the converters are far better than others and you may have better luck with another one.

2 Likes

Additionally to what @PimaxUSA has said it would be good to post your laptop model.

Some laptops run the discrete gpu through the igpu(ie intel graphics) through the usb-c.

Depending on how your usb-c DP is configured your laptop might not be compatible.

Hi Heliosurge
my laptop Asus tuf gaming
processor
Intel 11th Generation Core i7-11370H , Graphics NviDia Geforce RTX 3070
RAM 24,
i try the usb-c DP adapter with others monitors its working fine …i try it with oculus rift s ,working fine

1 Like

Also i try pimax artisan with another pc with Dp native same results( disconnect diagnose 10600)
same pc that was working in the past with this device pimax

1 Like

Okay your laptop looks very nice. If the Artisan was previous working with it your Usb-c DP adapter maybe fine.

With your other pc giving the same results that had previous worked. It sounds like maybe a problem caused during firmware flash. You could try reflashing the firmware. Support may need to setup a remote session to fix up this issue.

HI Heliosurge ,finally my artisan working now fine :innocent:
after ubgrade firmware the problem from DP not compined with gpu connect with motherboard
going to another pc with native Dp comined connect with gpu, its working now my poor arisan , thank you you Heliosuge for your care and all ur team stuff :slightly_smiling_face:

2 Likes

Your very welcome! I am glad your back to being able to enjoy your Pimax.

:beers::sunglasses::vulcan_salute::sparkles: