Pimax just lost forcing motion smoothing always on (with SteamVR beta update)

As from today (22.5.2021), SteamVR Beta update 1.17.10 removed “forcing reprojection always on”.
Up to that, I was using motion smoothing that way for my favourite game IL-2. With fps on half I had great graphic, and still playable game. Maybe other games do not need it, or do not need forcing it, but simulators can benefit a lot.

Is there a chance that Pitool get that option without SteamVR? (reprojection always on)
@PimaxUSA ?

My usual way for setting it was:

  1. Pitool turn on the smart smoothing
  2. SteamVR, settings, video, per application, “reprojection always on”

Is there any other way, maybe for non-steam games also?

PS: Reprojection without forcing always on is not good enough for simulators. Then I have small freezes every now and then.

1 Like

Most of those functions occur in our side of the driver anyway. The handoff happens very high up in the render pipeline so we supply functionality for texture allocation, texture management, compositor, scaling, distortion correction and more all happen on our side of the driver. We also bypass all Windows backend like screen mapping for the Windows API.

So often when you select something in Steam that setting is picked up in the driver and the change is affected on that side. As a result it typically (but not universally) only works if there is a corresponding capability on both sides.

This means especially in some steamvr betas there can easily be situations where a change can cause the render pipeline to function unpredictably.

My suggestion is if you have results in the svr beta that have negative consequences - first report it to us to make 100% sure we are aware and 2nd switch back to the release version until we’ve synchronized the changes.

8 Likes

I don’t know if this is the case for the game you’re talking about but in some games, like for example assetto corsa compétitions, you can set a Max fps number.
For example if I want a stable 45 fps reprojected to 90 fps I set max fps to 60 so it never tries to put 90 fps when it could and stay at 45 FPS.

4 Likes

Good point. You can also set the Max Frame Rate in the nVidia control panel.

3 Likes

There is one more way to force reprojection all time, I got it from pimax support:

1.Open the file “profile.json” which is in the folder C:\Users\Administrator\AppData\Local\Pimax\runtime.

PS: Some important files and folders are hidden in Windows to prevent them from being deleted by mistake, causing the system or the software to fail to operate normally. If the folder mentioned above is not visible to you, please show hidden files and try again.
For your reference to display hidden files:

https://support.microsoft.com/en-us/windows/show-hidden-files-0320fe58-0117-fd59-6851-9b7f9840fdb2

2.Add the following parameter at the end of the file:
(add “,” on last existing instruction, and then)
“dbg_force_framerate_half” : 1

3.Save change and exit. Then, please restart the service PiServiceLauncher in Task Manager.

Note:
1.With this parameter, the number of frames will be forced to half of the refresh rates and be locked, regardless of whether the FPS is in its full value.
2.It is recommended to uncheck the function “Turn on the screen saver” in Pitool when using this method, otherwise, problems such as screen tearing and delay may occur. In case these problems occur, please don’t worry, just restart the service PiServiceLauncher.

5 Likes

Nice one…! Thanks a lot for sharing @BrziJoe…! :slight_smile:

Maybe this can be added as an advanced toggle in PE, @SweViver (if it’s “OK” with the PiTool team of course)…? :slight_smile:

2 Likes

You may need to ping @arminelec to be heard

1 Like