Pimax VR Experience 0.70.0.0

backlight slider is not active for me in PE

Great update Sweviver! The download speed is pretty slow from your website though (200kb/s). Can you upload them to another service next time like Dropbox?

Update: This new Pitool and Pimax experience breaks the new brightness firmware. Now the brightness slider doesn’t change the brightness, but I do notice much less ghosting.

Works fine after restarting

2 Likes

I just installed the latest Pitool and Pimax experience software ard the backlight adjustment still works.

Hmm, that’s odd. Do you still notice ghosting though?

I have the backlight set to 91 and haven’t noticed any ghosting. I will have another look.

2 Likes

Definitely still working and I cannot see any ghosting . I tried Half-life Alyx and tower defence.

2 Likes

We are already testing this. It will require some methods which are not so optimal, because of the nature of how Pimax headsets reboots, but yes it will be added once its more stable.

What headset model are you using? The backlight for 8KX is not added (but it will be in next update very soon). All other headsets should work fine.

4 Likes

Yep, I agree. It was just a temporary solution because Google Drive was refusing my files to be shared (policy reasons). From next update will will host the files on the Pimax server. Im waiting for access :slight_smile:

You mean with 8KX right? This will be fixed later this week. The other Pimax headsets should work fine with brightness slider.

3 Likes

The backlight slider works with the 8kx if you download and install the beta firmware that was unofficially released a couple of weeks ago.

1 Like

Nevermind, after restarting the headset the backlight slider works just fine and the ghosting is gone!

1 Like

Yes thats correct, but just in case… until its more “official” we have disabled the 8KX brightness slider in PE. We will change that later this week :slight_smile:

2 Likes

Thats weird because it still works for me after I updated.

1 Like

With an 8KX?

202020202020

1 Like

Yes! After installing the latest Pitool and Pimax experience, initially it seemed the backlight slider wasn’t doing anything. After a simple restart of the headset, trying it just now, the slider works with no issue. I can increase the brightness and there’s no motion blur. :slight_smile:

2 Likes

@Sweviver

@NextGenVR comparing 8K X and G2 have used beta steam

It’s still valid what you said that beta steam reduce Pimax sde and definition because Pimax do not support motion smoothing ?

Yes but I have to change it in Pitool desktop not in Pimax experience. So I guess you meant it doesn’t work in Pimax experience.

1 Like

I’m using Steam beta because Valve fixed the blurry overlay on Pimax in the beta version of Steam.

3 Likes

Thats great to know, thanks!

I didnt know that motion smoothing affects the SDE? Either way, Im not sure if Alex and the team is up to some changes, but I suspect the motion smoothing might never be supported by Pimax due to the nature of the different rendering pipeline. But Im just guessing here :slight_smile:

Yeah thats what I mean :slight_smile: Thanks for clarifying!

Ive noticed the overlay image is way more sharper in Beta than in regular SteamVR version.
I suspect the GPUSpeed range has just changed in non-beta. So if you used 1500 before you need 2500 or 3000 now to keep the sharpness. This is the reason we increased the GPUSpeed values to minimum 2500 on default (overwriting all existing profiles automatically, to prevent blurry image).

4 Likes

Its funny my 3090 gives me 2700-2900 GPSpeed on its own. Which means without tweaks, 3090 is the only GPU that makes overlays sharp on 8KX :slight_smile: Quite a drastic move by Valve lol…

6 Likes