Pimax VR Experience 0.70.0.0

Stuck in PP mode. Doesn’t seem to matter if I try to change it from the desktop Pitool screen or from inside PE7.0, the chevron on the front of the headset keeps flashing. Note that I haven’t tested with a game that needed it to see if it’s just the chevron or if it’s actually not changing. Computer restarted once after new version installations.
I’ll keep playing around with it. -still on my 5k+

I’m on an 8KX but I noticed that the chevron light does not always change when PP is on or off now. I tried a game that needed it on and the chevron was not blinking but the game still worked so I know that it actually was on. I don’t know if the new pitool or the beta firmware that I installed is causing it. Hopefully the upcoming official release will sort it all out again.

Here the same issue…

In in the Windows Mixed Reality Home you could place objects in the room and start a game clucking that object. Also elements like the store or screen could be placed in the area/house. I did kind of like the idea but not sure how much you will use it after like 20 hours into it.

There’s a new (valid) PiTool upgrade available (1.0.1.266) in PiTool which is the same as 1.0.2.086 v7:


TLDR; It’s now “safe” to use the update function in PiTool.

@arminelec/@SweViver: You probably already know guys, but just in case You missed it, I’m tagging You anyway… :wink:

You might want to update these topics to avoid confusion as it’s now “safe” to just use the regular PiTool available via the update function… :wink:

Another note: Don’t forget to update the notice when installing Pimax Experience (the actual message box in the installer) as it says You need at least v1.0.2.86 (or was it 84) which may be confusing (in case anyone actually reads it)… :slight_smile:



Users will still need to re-install Pimax Experience after updating though! :wink:

EDIT: The PiTool package can be downloaded from here:

4 Likes

Thank you very much @DrWilken for tagging us.

Unfortunately (as an independent developer who has no communication with PiTool team) I have no way of verifying whether the new PiTool that Pimax released is the same as the 1.0.2.086 that PE works with or not.

But I will check the new PiTool out some time next week. Currently am in the middle of a change and I rely on the same PiTool 1.0.2.086 functionality when working on PE.

Again, thank you very much for pointing it out to us as well as informing and guiding the community! :slight_smile:

EDIT:

I just read a post by @PimaxUSA where he confirms that the two versions are the same (link below):

8kx terrible performance in steam after pitool 1.0.1.266 update? Steam VR won't open

3 Likes

They are .086 but not exactly the same. Internal revisions have the same overall version number but they increment version. i.e. we had .086 v1,2,3 etc. The previous version 86 (that was released in the official update) was v2 and 266 is v7. V7 was effectively a release candidate but I didn’t think it would go live because it has a couple of minor known issues.

4 Likes

Confirmed that with V1.0.2.086, the front chevron is no longer connected to the PP status. I can change it’s color, but whether or not it blinks seems to be arbitrary. Yesterday it was blinking, today when turned on, it’s not. The system seems to go in and out of PP mode just fine using the desktop app. Also switches without problems using profiles in PE.
Using a 5k+.

4 Likes

Support for 266 will be out early next week, but it relies on a few changes in PiTool code that the PiTool team needs to finish. Those changes are mainly tied to the connection requests/responds between PiTool and PE to make it all work.

Me and Armin finished earlier today full support in PE for the backlight brightness changes in real time without reboot, including 8KX backlight brightness support. We also improved the IPD Offset + Vertical Offset adjustments by adding locked+unlocked sliders for easier use. Plus some other improvements and few bug fixes we already have found since the release of 0.70 (related to refresh rates, profiles, etc).

Releasing this new PE update today wouldn’t make sense, until PiTool gets these minor changes done in the connection part. So let’s wait a few days.

Either way, from now on, or at least from next week and onward, the PE updates will be more frequent than before. Every update won’t be groundbreaking with new major features of course, but the progress is definitely speeding up now after the major work that has been done with the core.

If you ask me, Armin is a genius :slight_smile: Im not kidding. Keeps surprising me every day hehe. And its a blast to work together! And Im so thankful for all he is doing. I think we all should be.

Working on this project has never been more exciting than it is now. Im sure you will all appreciate what’s coming up!

Its all cool features but in the end, I prefer functionality and full customizations over fancy gimmicks :slight_smile: There’s nothing stopping us from building PE around a big dynamic environment with teleporting etc. But let’s get the important and useful features done first.

Yes thats a bug. And I have already suggested to the team, and idea that the chevron should only blink when tracking is lost. PP should not trigger blinking. It makes no sense I think. I suspect PiTool team is working on this change already.

Im glad to hear that, thanks! It will only get better from now on :slight_smile:

17 Likes

I actually use this feature. I switch between pp on and off fairly regularly and being able to tell at a glance whether I need to restart SteamVR, after switching, has been handy. Especially considering that the indicators on the desktop and PE have been iffy in showing the pp status.

Edit: while it’s obvious if it’s off and the game needs it, there’s no way to tell that the system is chewing needed resources by having it on when it’s NOT needed.

On the other hand I find the blinking extremely annoying so I think there should be an option to turn it off for those of us annoyed by it.

1 Like

Actually, there is: The RGB LED (by the headset power switch) is purple when PP mode is enabled and green when it is OFF.

At least that’s the way I understand it’s supposed to work. Running the latest PiTool (v1.0.1.266) seems to be stuck in PP mode. The chevron is still blinking and the RGB LED is always purple. Rebooting the headset seems to have fixed it. Now PP seems to actually be off: The chevron is NOT blinking and the RGB power LED is green.

It appears you need to reboot the headset, to actually switch PP on or off (after Applying the setting in PiTool).

6 Likes

I never noticed that, thanks!
That solves any issue I had with this.

I’m using V1.0.2.086. PP is definitely turning on/off, chevron is not. I’ll start watching the power button.

2 Likes

@SweViver When installing new Pitool version, does it automatically update the firmware of the 8KX to the latest version?

1 Like

Nope. Not if You’re on the latest beta released in the forum (I am and it didn’t update)… :wink:

2 Likes

Sorry if this is an obvious question. I just started using the Pimax Experience. Do I have to change the profile for every single game? Is there a way to just apply the common settings to all games?

4 Likes

Yes it would be nice to have a feature where you could mass apply the same default setting to all profiles. It’s kind of a hassle to set the same values for each one individually.

3 Likes

You could just point to common settings profile on each game once if You’d like.

That said I would also find it useful to have a kind of “global override” set of settings that where You could enable each option override (for example always use Normal FOV but keep the rest individual), and I already suggested this during closed beta… :wink:

As far as I understand it’s in their backlog.

3 Likes

maybe a possible easy add:
make a checkbox for this:

“power”: {
“autoLaunchSteamVROnButtonPress”: false
}

disable steamvr start when steam button is pressed.

1 Like

You can!

In profiles tab, you can uncheck any box that automatically applies the game profiles. This way you can manually apply a profile and it will remain until you change it yourself (or until you enable automatic profiles again). See screenshot:


I hope that helps, but if I misunderstood your question let me know.

5 Likes