Pimax VR Experience - 0.85.0.0 Public Beta - Discussions 💬

is this actually something we can expect eventually? change refresh rates without hmd reboot

Yeah, a way to launch SKSE and MO2 would be awesome.

First time using PE…when I set and save my brightness/contrast settings, either in PE or in Pitool, if I load a game through PE it changes a bunch of things: Puts my FOV to Normal from Small, turns on PP from off, resets all brightness/contrast settings, I only tried loading HL:Alyx so far, so I’m not sure if it’s game-specific yet…I didn’t choose any cloud profiles or anything. What am I doing wrong?

He doesn’t know if you’re asking aminelec that question

1 Like

PE has individual profiles for all games. You need to change the profiles for each game before you launch it to set your desired settings for any given game. Once you save the profile it will always set the headset up to those settings when you launch the game. The default profile for all games is set to normal FOV, with PP turned on and brightness/contrast set to neutral.

2 Likes

IMO the games should use whatever I have currently set in Pitool unless I specify a profile… instead of some default profile that I will have to constantly change for every new game. Pretty annoying tbh so I will probably still use my (platform) library to start games.

Yeah I was initially worried that it would be annoying the way it is setup up now, but after I got familiar with it, it turned out not to be a big deal at all. It literally takes me about 5 seconds to change a profile to the settings that I normally use for any game and it only needs to be done once for any given game. (PP off, brightness -3, contrast +2) The benefits of PE far outweigh that requirement IMO and I would never want to go back to not using it now.

What I do wish for though, would be a way to globally change the default profile to what I typically use. @arminelec?

You can! Head over to profile settings page (in Advanced mode (not Basic) > choose Profiles > Settings) and untick the checkboxes for anything you do not wish to be automatically controlled by PE.

You can!

  • Edit the “Common Settings” profile (in Advanced mode (not Basic) > choose Profiles > Edit Profiles > Select Profile > Common Settings).
  • Set the profile to the parameters you want.
  • Under Profile Settings page, untick the checkboxes for automatically applying profiles.
  • Restart PE to make sure Common Settings are applied.

From this point on, you can start any game and other profiles do not get automatically applied by PE… That is as long as you do not tick the checkboxes just before launching a game.

I hope this information is useful.

3 Likes

Thanks for the input. Added to backlog.

There is already a command line option to launch games with command line arguments. If that is not sufficient, would you please explain to me more precisely what you have in mind?
Please keep in mind that I do not have either skyrim se nor mo2.

2 Likes

Great, thanks… :grin:

2 Likes

Didn’t see it when tried to add a custom mo².exe I’ll look again. Maybe it’s after I add it.

Anyone else get the headset flicking when you maximize the PE window and then minimise PE window in desktop view?

You can add arguments on streamvr titles but you can’t add them on custom

1 Like

Hope I can get some help. I got rid of the monitor in the room where I use the 8kx trying to get advantage of the desktop view within PE. I mostly use software under Steam VR which is saved in C hard disk with the OS. Steam doesn’t allow me to save it in the other drive D where all steam applications are stored. Same goes for Steam VR, even under admin privilege. That means I can’t save any settings in SteamVR, which is annoying. Problem now is that whenever I close the SteamVR application I start via PE, Steam VR hangs, not allowing to go back to desktop view in PE and I have to walk away to reach out to the other station to close the application using a monitor connected to the controlling computer. Would be possible to have a short cut to close SteamVR and/or have the equivalent of the Windows key so I can close any open window and/or access to Alt tab and go back to desktop view in PE, so I can shut down Steam VR while wearing the headset?

EDIT: SOLVED, IT WAS PROBLEM ONLY ON MY SYSTEM!

Hey guys, finally I updated and tried PE ipd settings; it is great that we can click +/-0.1, and to have left and right eye interconnected.

But…
In PE booth for left and right eye ipd- (ipd minus) make me more cross-eyed.
In Pitool left eye behaves opposite; there ipd- means less cross eyed (right eye is same in PE and Pitool)

I was checking that 2 times now. I know it is a little bit better for me to set software ipd a little cross eyed, that was in Pitool left +0.3 and right -0.3.

Same setting in PE is -0.3 on booth eyes.
How it is possible?

PS: Pitool 268, PE 0.85 updated to .02

Please discharge my last message; today everything works same on Pitool and PE.

Yesterday something was wrong in my system, but now it is OK (after restart). On booth eyes ipd+ means more convergence.

Finally spent a lot of time trying out Pimax experience. Its unusable for one reason:
The color profile does not stay for Red green and Blue. It keeps resetting to All.

This color profile should not be set for each game and should be part of advanced HMD settings. I spent an hour configuring them for each game and couldn’t use it during game,

I just had a thought on how to implement refresh rate switching without having to worry about the program lifecycle.

  • Have the ability to set the desired refresh rate for a game
  • Check if the current headset refresh rate matches that
  • If not, replace the “Play in VR” button with an “Apply refresh rate” button.

This isn’t an ideal solution but it would solve the issue of booting up a game only to realize you forgot to change the refresh rate again.

1 Like

hello all, steamvr.vrsettings file and update via PE.
With latest PE, this file still cannot be updated with PE. PE is reporting a notice that steamvr is not installed and/or some other issue is blocking the update. The root cause appears to be the location of the file. It appears that PE is looking for it in a static location; however in my install its located in a different location (…\AppData\Local\openvr\steamvr.vrsettings). Thus, either is there a PE config file where the location of the file can be changed, or is there some other way, perhaps a config in steamVR, to locate the file in the location where PE expects it? Currently, i need to manually update the file before i open steamVR; however, would love to use the PE feature that automatically updates this file with the optimized settings to maximize steamVR render.

UPDATE: Ended up completely uninstalling SteamVR as well as the openvr reference and other old steamVR associations on my machine. Rebooted and then ran fresh install of SteamVR from steam. Loaded up Pimax PE and now the optimizations work successfully! Looks like the default location for which PE will function is: …\Steam\config\steamvr.vrsettings
The above file is being updated when auto optimization runs via PE. Joy!

Yes this is a bug I noticed too first time I used it. It’s still there so hopefully will be fixed soon.

That said, for now a workaround is to save your game profile once you have made all necessary changes such as PP etc but cricually before any of the colour correction ones, then go into the colour correction part, do those and save it from within that submenu. Do not then apply or save it from the main menu manually otherwise it overwrites the colour profiles again; just let it auto apply your profile on game start up and it will load the colour profiles correctly which you input previously.

1 Like