Pitool Discussion

Agreed, Since the 144hz had some profiling issues.
for my 203 headset at least, it was not aligned properly.

been waiting on an update for it, so i can swap to it.

1 Like

Oddly, though I used the 5k+ in 90Hz for almost a year, I can no longer stand the FOV shape. It’s like a projected rectangle. 120Hz and 144Hz are egg shaped and more natural to what the human eyes FOV is shaped like IMO. For that reason alone, even if I cant hit 120 FPS i dont change it.

  1. Does 144HZ change the IPD ? I struggle to find a good setting while never having any issue with that…

  2. When will a new pittool be released ? On rfactor, I still struggle at 50% of GPU usage ^^

noob question… what is the best way (right etiquette) of upgrading/downgrading pitool? Uninstall then remove folder from Program Files(?) …and stop service(?) restart after uninstall… a bit confused on whats required to do it the right way. I’ve seen someone mentioning that nothing is required - just install the new one over the old one.


I just install the new one over the old one. Downgrading might need removal first (but I’ve never done it, so I can’t offer advice for that).


I agree that you can usually just install one over the other. To be safe before running an upgrade I always do this:

  1. Ensure PT is not running and the headset is turned off
  2. Better still, unplug the headset from the USB and Display ports to be 100%
  3. Run the PT update
  4. Reboot (probably a service restart is fine but hey)
  5. Connect and power the headset and check it is picked up by PT
  6. Reboot again (probably not needed / service restart enough but hey :slight_smile: )
  7. Check to see if things run better or worse than before :wink:

You can go back as far as PT 245 without having to flash older firmware (assumes you are now using firmware 255).

While not necessary to do a clean install meaning just uninstall and install earlier version, I had found I actually had to do a clean install to gain performance back I had lost in a PT update. ymmv

To do a clean install:
1 turn off the 3 Piservices running in Task Manager.
2 uninstall Pitool in Apps and Features (this will remove the Pimax folder in
c:\ Program Files folder)
3 delete the pimax folder in c:/Program Data folder
3 delete the Pitool and Pimax folders in c:\user???\AppdData\Local
4 delete the Pimax folder in c:\user???\AppdData\LocalLow
5 delete the Pitool folder in c:\user???\AppdData\Roaming

Reboot and install earlier PT version.


great info guys… these should be pinned somewhere - unless it IS pinned somewhere and I havent seen it yet lol… I just got my 5k+ a few days ago and been having issues with keeping constant FPS with a fairly high-end system (9600k @5.2 + 2080ti - custom water cooled). I tried almost all combination of settings with no luck. Then I downgraded to what Ive been reading was the last 99% stable build [197] and had major stutters - unplayable. Tried 253 and got the same thing. So, I thought i was doing upgrading and downgrading wrong. went back to 255 and everything is ok but subpar performance. Excited to try 258 today and see what it does… fingers crossed. thanks for your help

1 Like

Smartsmoothing adds a way less artifacts in 144hz mode than 90 or 120hz thats why I’m using 144hz/72hz mode for most modern simulators. ( ACC, PC2, IL2 , Dirt Rally 1, 2) Mind my 5k+ is 204 revision


Well ok I’ll do more test, thanks for the advice !


Looks like the smart smoothing isn’t active on ACC… Anything special to do ? I disable mirror by the way.
BTW ACC starts to be really well optimized for VR. Sounds promising.

1 Like

Maybe in game sync. or fps limiter ?
My seetings are here : https://www.assettocorsa.net/forum/index.php?threads/sharp-as-orginal-ac-my-way-pimax-5k-rtx-2080ti.62356/#post-1126234


In fact, it isn’t active on any games :confused: I activate it on pitools but it looks like it doesn’t really apply… I think I will wait for the next pitool…

How can You tell it isn’t enabled?

If it’s because it says “closed” in PiTool it won’t actually show it as enabled (or active or whatever it says, don’t remember) until it’s starts running at half the frame rate. I.e. it’s only shown in game when target framerate isn’t reachable and thus is cut in half.

Also, if You’re using the per game settings You have to start the game from PiTool for it to work after switching to the profile (otherwise, just enable/disable it on the global settings page instead).


it’s not enabled because : it’s not smooth at all, and there is absolutely no artefacts.
It says inactive in pitools.
I tried everything. From pitools, from steam, with game settings, without. I even reinstalled everything. But no big deal, it’s already satisfying without smart smoothing.

my pitool finally updated to the latest software/firmware and now nothing works for the first time since I got the device last summer.

Link for pitools

Smart smoothing was active in RF2. I don’t see the difference in terms of artefacts. Otherwise, it looks extremely smooth. It makes a difference when driving a fast car in a straight line !

all I get now is the Pimax logo and nothing else works… the pitool is showing no issues and steamvr detects HMD fine as well.
not sure what happened. one day (for almost a year) everything worked and now after this latest update nothing work anymore…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.