PiTool 1.0.1.275 Discussion

Tried it, and tested it for a few days, and 90Hz works flawlessly for me.
I replaced my cable with the optical cable after updating, but that worked as well.
JFYI, 3080/5800X.
I wonder if it has anything to do with the hardware iteration.
Mine is a pre-order 8K X.

4 Likes

Just built another computer. This time I used the new 275 version of Pitools.

I installed SteamVR and then PiTools (I still prefer “Peetools” :smiley: ), shut down, hooked up my headset and restarted. It auto-flashed my firmware, without giving me a choice. The first time it failed. I suspect that it failed because it was attempting to do this as my computer was starting up. By the time it failed and gave me the opportunity to retry it, my computer had finished starting up. The second attempt was successful. More importantly, apparently it flashed the correct firmware because it worked! I did have some odd issues with SteamVR (I had to reinstall it) but things are working well. I do have a 90hz option but I have not tried it, yet. PE software successfully downloaded and installed when I changed to it in PiTools. I had a few issues but they were self introduced. Overall, I’d say that this was a good experience!

One interesting note. I have 3 monitors and, on a new build, I normally have issues getting the 3 monitors to be recognized as 4k monitors and then have issues seeing the displays on the headset. This time I tried a trick that I read about that shouldn’t have had any effect: I went into the bios and selected my pcie display rather than leaving it on auto. This time installing the monitors and then the headset was flawless. No plugging and replugging to find a working port on my card! Of course, it could have been the card (finally got my Strix!) but my guess is that it was the bios setting change.

If anyone is waiting to hear how this release works, I’d say it’s a success and you should go for it!
Keep us posted as to your experiences…

3 Likes

I’m running the latest nVidia drivers and the latest PiTool. I have no trouble using 90 Hz on my 8KX, which is great, since I only have an RTX 2080 (and it’s not guaranteed to work on that model).

Note that I do have an issue with SteamVR detecting my headset, but as long as I reinstall PiTool before running a game (after turning my headset off), SteamVR can find the headset. It’s a bit of a pain, but at least everything is working (including 90 Hz). This is not a recent issue for me; it’s been a problem for the last 3-4 releases of PiTool.

2 Likes

I have a 3090. Only the 298FW worked for me - no matter what drivers or PiTool Versions (if new enough).
So currently that is PiTool 1.0.1.275 and FW 2.1.255.299 and the latest NVidia Drivers 511.65. I havent tried the 298er FW since I keept hoping that there would be a fixed FW “soon” :crazy_face:
Edit: I am still on the original cabel, no the new fiber one.

2 Likes

:triumph: … dammit …

I knew why I didn’t really want to do the update:

I uninstalled everything cleanly including all subfolders, installed .275, re-booted - and just went downstairs for a couple of minutes while the PC was entering Windows.
When I came down, PiTool autostarted itself and said “firmware update failed”… once again … like with the old .270 before, too.

When looking at the hardware manager, look what I found… again… :

grafik

Didn’t they say, the issue should have been fixed with .275 in the first post of this thread…?!? Well - at least I understood it this way when reading:

Fool me…

Now, that nice little LED once again is blinking in all the rainbow’s colours, I have to attach the HMD to my convertible, and then see how to reset it and do the firmware upgrade for .275, just waisting precious time.

Ey @PimaxQuorra : If you / Pimax simply hadn’t the best VR headset for my purpose, I should think about quitting you… This issue persists since more than one year now, at least, it has been confirmed, there are workaround guides here on this forum, and you are still not able to fix it!! Shame on you!


Oh, c’mon - not really:

grafik

=> Direct link to Pimax VR Downloads is still dead !

Where do I get the latest firmware for my 8K-X now from? And which is the correct version?

Honestly:
I forgave you everything at the beginning and during the 5K/8K kickstarter a couple of years ago.
But now, 3-4 years later, still noob issues both in software as well as on the homepage.
=> Unbelievable. And little by little not regratable any more.

This should help.

2 Likes

Thx :slight_smile:
Yeah, I am already into it… and I am happy to have a “clean” convertible without the PiTool software itself. So I probably can skip all that “cleansing” and DDU stuff and just flash the 299 DFU with the dfusecommand.exe as I did last time.

Nevertheless: :triumph:

3 Likes

It’s a little late now, but when you came back to your computer and had the message stating that it failed, did you click the “retry” button? When I did that, the second time worked fine. I assumed that it was an issue with attempting to flash firmware while the computer is still booting…

2 Likes

Yes, I did so, “retry” failed as well.

And as highlighted in my screenshot, the 8K-X still is misidentified as my Thrustmaster steering wheel… so, generally not really astonishing, I think.

Besides, it worked after flashing via my convertible. Already did two short sessions, no major issues.
(Except that FFR is still not working with activated PP; apparently only in non-PP games or Oculus mode…)

But: Now, pi_overlay.exe is moaning each time I close PiTool:

With the old .270, I had this issue perhaps once a month or even less - now three times opened, three times closed => 100% failing pi_overlay.exe …

Can anyone confirm?

No firmware glitch. No fix for the 1/3 smoothing.

There’s no flash glitch. There’s no 1/3rd fix

Okay, so with .275, something is really weird now:

I played an hour this morning, closed PiTool, and Reliability Monitor showed once again, pi_overlay.exe was not working properly any more when closing PiTool. So far, so bad.

Now, I want to start another session, launch PiTool - and get PiOverlay always launching as separate window as well:

When I close it, it restarts itself automatically.

This never happened with any version before.

And always generating failure entries:

works with a Pimax 5k+???

Are you exiting PiTool when you close it?

If so, the headset wont work - it needs PiTool running in the background. Just minimise it.

I know.

I am always switching secondary USB power “on” and starting PiTool when I use the 8K-X, and I am always closing PiTool and switching secondary power “off” when I don’t use it. Otherwise, the headset just draws current for nothing for hours, and the PC itself, too, is more busy.

Worked flawless since 4K times this way three or four years ago until .270 included (version I used until yesterday before upgrading to .275), and I never had this issue before. (Except, the 4K didn’t have the secondary power, of course :wink: - but I did the handling with the old Pimax software this way already then.)

I will revert to .270 and see whether the issue is gone again then. If so, it is .275 related.

2 Likes

Installed .270.
Set up everything (colors, room setup).
Closed PiTool at 5pm03.

=> no new entry in Reliability Monitor:

=> definitely .275 related, at least on my machine.

And concerning PiTool and powering off - I also watched the load and temps:
While PiTool is running and the HMD is on, “idle” load of pi_server.exe is “low” with ~1%, and GPU temperature stays at ~64°C… although PiHome is off and the HMD is just showing the B/W configuration screen…

So I prefer handling it the way I did it for several years now :wink:
Besides the fact this can’t be the cause of the aforementioned issue since it wouldn’t have gone away with .270.


Ah, just another hint for everyone upgrading PiTool to a new version:

After PiTool installation, before rebooting your PC, go to “Autostart” in Task Manager and deactivate PiTool on autostart. This way, reboot is “safe”, and you’ve won the time to think about how to upgrade the HMD’s firmware properly without running into the DFU issue :wink:

2 Likes

I have 3090 and PiTool software 275 and firmware for Pimax 8K X 90Hz and 90FPS all the time at 4K iRacing res… P2_DEBUG_8KX_M299_t20211101115020_r85cdd55_forEnableHDCP from support as you have it with latest nVidia 511.65 drivers and for iRacing Ryan settings … it works first time without flicing…
The only think is that Pimax Hand tracking do not work… :frowning:

It might or might not be related to .275 and firmware 299, but I think I will post the link to my latest issue thread from today here, too:

… stay awake - and never change a running system without need :wink:

1 Like

What version is your Nvidia driver, firmware and Pitool?

1 Like

Anyone running 5K XR with 275 and FW included with it and no issues? I am still on 269 or 267, it works rock solid and afraid to update reading above issues hitting Neal…

1 Like