Pitool 254_ALPHA no stutter/judder confirmed

CPU: i7 7700k
RAM: 16GB @ 3000/15
GPU: 1070 non TI
Headset: Pimax 5K+ 203…
Pitool: V1.0.1.254_ALPHA
Firmware: V2.1.255 .255
Nvidia: 441.87 Driver
Tracking: 3Dof (no Station)
Windows10 (x64)

To me the Combatibility-Win8 MOD did work, but i was curious if the new Pitool 254_Alpha driver is solving the stutter/judder problem.

  1. I´ve manualy turned OFF Pimax 5k+
  2. Exit Pitool.
  3. I´ve made a clean uninstall of old Pitool version.
  4. I´ve also deleted all folders Pimax/Pitool created on my system, even folders in “Appdata”.
  5. Restart Computer.
  6. Run Pitool .254_Alpha Setup as Administrator.
  7. Run Pitool and made my usual settings.

Started some VR-Games and yes it´s working for me, no stutter/judder found or compatibility Mod needed.

I also could even raise resolution up a little bit (Assetto Corsa and Skyrim VR) runs better then before
but unfortunetly i had to lower resolution in DCS a little bit it runs worst than before.

FpsVR tells me that the GPU Frametime is more balanced now.
Looks good, Pimax/Pitool is going to the right direction now.

I hope the new driver solve the problem to all you other guys having the stutter/judder problem, i wish you good luck!

19 Likes

Download here (it’s an alpha, so it’s basically untested):

As noted: Do NOT update the firmware (it’s done manually) unless You have a 5K+ with a serial number starting with 2026*!

3 Likes

Dirt rally 2 - gpu utilization 95%!!! This is the best pitool for me. Before my gpu usage was 85%, now 95% and no more fps drops. Thank you!!

6 Likes

I hope we get a working version of this for Pimax 8k users, I’m so tired of the judder.

2 Likes

Very happy about the effort from Pimax, thank you guys for finally formally addressing this. Gonna try it tonight!

4 Likes

Give 254 alpha a try it may help in your situation as well.

3 Likes

Has the ‘Backlight Brightness’ setting been re-enabled on this?

3 Likes

no, but i dont feel it´s needed. I adjust picture-quality with “contrast” and “brightness” slider in Pitool. For every Game i use a separate Pitool-Gameprofile and adjust Ingame-brightness if available.
Works just fine like that.

3 Likes

im curious do you have to launch the game from pitool to have the color settings per game take effect?

2 Likes

i´ve tested it on Skyrim VR real quick for you. So if you start the game from Pitool u can even ALT+TAB and switch back and forth between game and Pitool and change “contrast” + “brightness” on the fly. No restart of the game needed.
Once you “Applied” and “Saved” settings in Pitool, you can close Pitool and start the game from Steam and the settings will be just like you´ve adjusted in Pitool.
I think it´s very nice like that.

4 Likes

So I gave it a try however after installing it and connecting my 8k it’s started updating my firmware, and since there’re huge capital letters saying “WARNING FIRMWARE ONLY FOR 5K+”, I stopped the firmware update and went back to 144, and everything is working fine.

So if some hero (or idiot) want to play hero and let the firmware update finish be my guest, I won’t.

Heliosurge, you have an 8k, would you do the honors? :wink:

3 Likes

Just to see if the 254 firmware update is not related to this version specifically, I tried the 253 version and I get no firmware update at all (but huge stuttering as expected), so it’s something related only to 255, so I’d stay away from it if you’re an 8k user just in case.

The new PiTool Alpha .254 has the same firmware bundled in it as the PiTool .253 thus it is perfectly fine to be used with the 8K and non s/n 202 5K+ headsets also.

Try it out, maybe the stutter problems might be better for you with this version as they state it in the release notes that they have tried to make some improvements now.

Here where the PiTool Alpha .254 was announced there was a experimental firmware for the s/n 202 5K+ headsets only for which as a compromise Pimax is offering now the 110Hz mode.

It seems as this s/n 202 5K+ firmware was mentioned in the same post, some people mistaken this to be included in the PiTool Alpha .254 which it does not.

3 Likes

So can you explain why when I install 253 I don’t get any firmware upgrade message, but on the other hand pitool tried to update my firmware in 254? You say it’s the same, why is it trying to upgrade then since it should be up to date?

Is this version for any other headsets? Including 5K+ (SN 203+), 8K, etc?

3 Likes

Yes, that is the new version which is ok for all headsets and does not include the s/n 202 5K+ only firmware.

3 Likes

When I updated from PiTool .253 to .254 with my s/n 202 5K+ I did not get any firmware update prompt so I assumed it would be the same version which comes with the PiTool .253

What ever the version is, it is not the s/n 202 5K+ only 110Hz firmware but one which should be fine with all of the headsets.

I later manually flashed the new 110Hz s/n 202 5K+ only firmware to my headset.

I think the stutter is a bit better now but still not completely fixed compared to PiTool .144. Did not have the time to test the 110Hz yet.

1 Like

I tested the alpha version .254 pitool with my serial 203 5K+. Intel 9700k. 2080ti.

I used the 120 Hz mode for all tests. Compared to version .253 it appears to have the same amount of GPU utilization in Elite Dangerous and Skyrim VR. Both hovered around between 87-91%. No noticeable increase or decrease in fps. Just normal fluctuations.

As for the stutter. I had a few minutes to test it in Skyrim and that appeared better. Looking around keeps the image stable without any serious stutters. I had one noticeable stutter in Elite Dangerous but that could have been due to the game still loading. Looked around for a few minutes and it seemed stable.

Overall, it appears to be an improvement over the .253 version, so I am optimistic that we are heading in the right direction with these changes. More tests will follow in the next few days.

Side note: I am very pleased with the 120 Hz mode! The distortion profile is very good and the world feels very stable in the high refresh rate.

5 Likes

Great news, I’ll check it out when I get home.

1 Like

Just tested this firmware on my 2026 5k+.
110hz mode does indeed work. Thanks to pimax for this special service. We 2026 owners are not left behind. 110hz is great in Beat saber and smart smoothing @ 55FPS works as well.

Keep up the good work!

7 Likes