Pitool 271 5k+ smart smoothing doesn't work on RACEROOM (works with 270)

Date: 02/07/2021
Issue Title: smart smoothing doesn’t work on raceroom with the 271 pitool.

Hi.this is a report to pimax staff.
After hours of trials on AC, ACC, RF2, PC2, Raceroom on my 5k+, alternating between pitool 270 and 271, I came to the conclusion that smart smoothing doesn’t work on Raceroom with pitool 271.
The other games I listed work fine, but raceroom : smart smoothing works like a charm on 270 but doesn’t work AT ALL on 271.
I have tested everything, including forcing half framerate, but all I have when I do that is half frame rate, no frame reprojection at all. (I know how to recognise a reprojected frame thanks to the artefacts).
I tested it on 90hz, 120hz and 144hz mode.

I have an OC 2080ti, OC i7 10700k, 32Go RAM
5k+; the latest nvidia driver.

until there is a fix, I’m gonna stay on pitool 270 cause Raceroom is becoming one of my favorite racing games since I bought all its content in one shot few days ago.


Also, I have no idea if it may be related or not but there is something very uncommon with RaceRoom when it comes to FPSVR monitoring data : the GPU graph is almost empty, I’m not saying it’s green, I’m saying it’s almost empty, the time between frames is like 0.3 ms.
I have never seen that in any other racing game.
Anyone nocided that?


Another thing pimax devs may take in account to fix this issue : RaceRoom is a directx9 game. (No idea if it has any importance here)

I confirm.
I have exactly the same symptoms and at the moment this is the least suited game for my computer.
i78700K, rtx2080Ti, 16GB ram

I have OC I7 10700k,(around 5.1Ghz) OC rtx2080ti, (around 2000 Mhz) 32GB ram, 5k+
I have good results without smartsmoothing in 72hz mode, normal fov : stable 72 FPS, with about 20 cars, offline, or multiplayer. total supersampling 176% pitool quality 1

I also have good results with smartsmoothing (pitool 270 then), 120 Hz mode, normal fov, stable 60FPS
total supersampling 176% pitool quality 1.
overal good visual experience.

the settings in game.
graphics level : custom settings
Car reflection quality : simple cube map
car shadows on
contact shadows 15
shadow split on
car texture quality high
rear view mirror quality low
visible cars 14
car lod distance setting low
shader quality medium
particle detail low
track level of detail medium
track animations on
track texture quality high
shadows lowest
tiremarks on
specular on
multi sampling 4 x AA
fxaa off
bloom off
motion blur off
motion blur quality low
lightshaft off
lens effects off
depth of field off

I have set a button to not mirror the visual on the monitor/TV which saves some resources.

I hope you’ll find it usefull.
of course this is not a definitive setting, but I think this is a good base.
with pitool 271 I will take the first option 72hz, no smart smoothing.

If I use pitool 270 I will have the choice between 3 options 120 hz+SS, or 90hz + SS, or 72hs without SS.

let me know how it goes with those settings

1 Like

The only thing is : the last 3 multiplayer races I had, I ended on the side of the road, with zero fuel left for the last lap, lol.
But this has nothing to do with pitool, it’s all on me ha ha !

I had a little fun. I applied your settings and it’s better, smoother.
Actually smoother 60FPS with 120HZ SS.
But I will choose without SS and then at the moment I have an average of 77.9FPS with SuperSampling set differently
How did you check it: Total supersampling 176%
I think I have 1.25 in Pitool and 100% in Steam VR.
It’s best if you take a photo in Steam VR and Pitool, and FPS VR
Many thanks for your willingness to help.

first of all, what headset do you have?
for my 5k+, I set the base supersampling at 100 in SteamVR, and then I go to per application and set it at 176%
the total supersampling = base SS x per-application SS
So if I set the base at 100% (which is the recommended resolution for the headset, taking in account the mask it has to apply for the lens distortions, so it’s a bit more than the native real headset resolution), it is easier to calculate what will be the final SS, because it will be the same as the per-application SS.

but my 176 total SS gives me to a certain resolution at normal fov on my 5k+
if you have a 8kx, 176% will probably correspond to a much higher resolution.
but considering you number I guess you have a 5k+

Now there is another thing to take in account , it’s the pitool quality.
1.25 is equal to a 1.25 x 1.25 = 1.56 SS multiplicator
so with 100% SteamVR SS, and 1.25 pitool, you end with 156% SS
to get to 176%; you have to use a 112% Steam VR total SS
because 1.12 x 1.25 x 1.25 = 1.76 (176%)

I have exactly 5K +.
Tomorrow I will check what you suggested.

I don’t see any difference in severity between 156% SS and 176% SS.
Your full setting, i.e. higher SS, puts a heavy load on my equipment at 60 FPS, whether it is with or without SS, while 156% with SS off and on and 120Hz works great, mega smooth.
I am annoyed by the fact that the maximum graphics load in FPSVr is 60%, and the processor 37%, I cannot reach a higher value in any way.
I remember that once a long time ago, maybe a year ago, I had everything in this game to the max and 120FPS, but the graphics load was at 88% and it did not fall below that, and the processor did not go below 50%.
Chybha I changed too many drivers and it all changed, but I didn’t control it and it is as it is.

1 Like