PiTool 272 and Firmware 299, Nvidia 2080 - uncommon issue

Hi all,
I read a lot about issues with latest PiTool 273 and Firmware 299 for 8KX here. However my issue is that after flashing the firmware either automaitcally by PiTool or manually with the here provided files, the Headset is not recognized by PiTool anymore and the LED is always green as soon as the headset is plugged in the computer (also without PiTool running).

Using other versions of PitTool does not solve the issue. Only flashing back to 298 and using PiTool 271 helped.
Most other talk about flashing or pixelated image, but for me the situation is as above. Anyone have a suggestion for me to get it work?

Thanks!

It has happened to me, the only way to make 272 + 299 work is in a single displayport port of my RTX3090. But even being able to start the Pimax 8kx it is not stable for me, there are very constant artifacts and blackouts. The more or less stable combination for me is Pitool 270 and firmware 298 of July the P2_8KX_M298_EngineerTest.dfu

I suppose you have tried changing the DP port and restarting the PC and all those recommendations.

Thank you for your reply!

Yes, I tried all 3 Display Ports and two NVidia drivers. It would be good to at least know why the headset is not detected and the LED is constant green. The others with issues have the headset at least detected and I did not see someone describing a change in LED behavior.
I am just worried that this is persistent for me with the next PiTool versions to come.

When it wants to work, the led is white, as if it were in standby mode and after a while it turns green, but it is very unstable and returns to white. Nor have I read that this color change occurs to others in the LED for the standby mode, going from red to white now. And I have had moments that the led stayed green but the HMD was with the screens off, error in pitool but the monitoring and the audio work, a festival of errors that I did not want to maintain.

I’m having a similar issue. I installed Pitools 272 on my system, it has AMD RX 6700XT. It did an auto firmware update and now my HMD is not fully detected by Pitools. When I go to the Diagnose option under “Help” It shows everything is connected except for HDMI/DP. I’ve tried different DP ports on my GPU and still nothing, just sits with a Yellowish/White LED near the power button and no display. I don’t even know what firmware version it actually updated to because I can’t see the headset in Pitools.

1 Like

Thanks for your post,
similar but not exactly identical to my issue and there is still some hope left for you.
There is a file of the 299 firmware (which is flashed by PiTool 273 to 8KX) that helped some people to bring it to work. You will find it easily on the forum.
If it does not help you need to revert back as well and hope Pimax will sort it out. Thats what I do now :frowning:

2 Likes

[updated again (twice)] I just had the headset disconnected issue again and have determined that uninstalling PiTool and rebooting my PC are not necessary. You only need to reinstall PiTool 272 and the “headset can’t be detected” problem goes away (at least for a while).

For me, the connection issue seemed to be related to PiTool, not the firmware. I suggest manually flashing the firmware to .298 (assuming you have an 8KX). Then uninstall PiTool, reboot, and install PiTool 270. The disconnect issue started at PiTool 271 (at least for me). Don’t forget to re-enable your Pimax headset and restart SteamVR, if you get a message from SteamVR saying it was disabled.

After manually installing the latest 299 firmware (Pitool v1.0.1.272 Beta - use separate firmware - 2nd link), I have been able to use the latest PiTool and Firmware, but only after uninstalling PiTool, rebooting, and reinstalling PiTool 272. Sometimes, the headset will stop being detected, but repeating those last 3 2 steps fixes it again. I think that PiTool must somehow corrupt one of its files or settings.

Firmware link:

PiTool 270 link:

1 Like