Pitool 277 pi_server.exe high cpu usage

Am I the only one who has 60-90% usage by pitool’s pi_server.exe now?
Happens even if headset isn’t on.
Doesn’t happen on 275. Can’t play even SteamVR menu because of terrible lags at 277. :frowning:

Best recommendation downgrade to 271. If the 8kX firmware 299 is giving an issue flash debug FW 296 and then upgrade manually to the 298 FW that worked best. 296 will clean out 299.

1 Like

I have noticed that issue and for some reason my 8kx image is less clear as well. I’ve never had serious distortion issues, but this latest i combination of pitools and firmware has really degraded the images.
How do I backtrack? I’ve forgotten the process.

Follow my post above. Run DFU.exe? In pitool folder and choose the firmware file to flash.

For downgrading pitool some uninstall & delete pimax related folders and run a program like ccleaner.

Myself? Have usually just ran the pitool installer of the earlier pitool. Just be sure to kill pimax processes before running the installer.

Firmware needs to be manually if need to roll back firmware.


I didn’t flash firmware back - just installed older pitool over 277 and it worked great for me after.


Hopefully once the lockdown ends they can put resources back into developing pitool more like they used too.

1 Like