Pitool Beta v1.0.1.271 Discussion

Not really. The overhead is due to many extra pixels being rendered, which is unavoidable (since the solution is angling the viewport, eg the non-PP case). The developer of the game engine must implement the fix. Basically, PP is a hack to fix the lack of angled viewport support in games.

There is one thing you can do to reduce the overhead: Reduce your FOV. PP requires progressively larger numbers of pixels for wider FOVs. I’ve mostly been using Small FOV for that reason.

2 Likes

I expect the vast majority of Pimax owners bought the Pimax, however, to use Wide FOV settings. Otherwise you have an array of vastly cheaper HMDs available, and they keep getting closer and closer in terms of clarity (the new Valve Index is pretty good and the entire kit is $999). FOV is the thing setting Pimax apart from everyone else, so IMHO they would make it priority #1 that the FOV can actually be, you know, USED.

That said, with my new AMD CPU and a 3080Ti I can finally make use of Wide FOV in many more cases already, depending on my usage scenario. In AC I’m up to 1.5 quality in PiTool (SS in Steam does not work in AC for me, but PiTool quality does), and hopefully Skyrim VR will eventually work IF Pimax fixes my aforementioned bug between PP and Motion Smoothing in that title. Dirt Rally 2.0 also runs plenty fast enough even with PP to use Wide FOV and a high SS (I’m around 1.20 in that title IIRC). On the other hand, in PCars2 I can finally use Normal FOV, that title just has the worst performance imaginable.

But ultimately, that PP<->Motion Smoothing bug in Skyrim VR is going to be a killer for me; I’ll have to remain at Normal FOV or I’ll have to reduce the resolution way too much. If Pimax fixes that I’ll be able to play Skyrim VR at very high resolutions in wide FOV and with PP on, at 45fps with smoothing.

3 Likes

We continue to try to improve PP and reach out to companies to optimize their titles to eliminate the need for PP. Some have indeed made many positive changes that affect our headsets and we will not stop reaching out to developers and work with them as much as possible.

Here is a helpful link:
In this google docs they try to document what titles need PP - you can check it out here:

In the list there are 198 games don’t need PP and 78 that require it.

Popular games like DCS, iRacing, HL:Alyx, No Man’s Sky etc. don’t need PP. Many of the games that DO require it have a high frame rate anyway like Beat Sabre so it can be enabled most of the time with little or no problems.

Btw, last time I played Skyrim it was widest fov and without PP but it’s been a while. Maybe updates or plug-ins caused it to be required again. I would add FSR has been reported to work great with Skyrim so you might also give that a shot!

2 Likes

I did too. However, I’m pragmatic enough, so that I’m willing to “make do” until I can get a better graphics card. For now, I’m stuck with a 2080.

It does depend on the game, though. I can easily use Normal FOV for less demanding games, like Half Life: Alyx. It’s the PP requirement that makes so many games unplayable with wider FOVs.

1 Like

Man, for me everything works in Skyrim. The only pp=off problem are loading screens, I ignore that, and play it pp=off. Also Pimax foveated rendering works here excellent, and AMD openvr solution also. Skyrim has one of the best performance of all vr games, especially without heavy mods.

PS; Motion smoothing sometimes start artefacts, then you need to restart game & pitool.

1 Like

Have you tried Skyrim without PP? I never use PP with it and the only issue I’ve seen is with the loading screen.

3 Likes

Yeah, I know a lot of people say that, but there are definitely issues with Skyrim without PP. There are problems with shadows, and occasionally with lighting, especially as the objects in question get closer to the edge of vision. Then there is the water issue as well (very slight mismatch between where the water should be and actually IS, only at certain angles). I will say they are very minor, enough to the point that many don’t even notice them, and I’ve often tried to get used to them as Skyrim VR’s performance without PP is indeed fantastic. Unfortunately for me I’m one of those people who notices things like this immediately and I just can’t un-notice them. The instant a shadow isn’t laying at the correct depth (bridge into Riverwood has this issues quite noticeably) or a light-source isn’t right all my attention is drawn to it. I’m also one of those people who absolutely can’t stand watching 4x3 video incorrectly stretched to 16x9 (poorly setup sports bars, anyone, anyone?) and I’ve seriously sat there and talked with people who literally can’t even see the problem. I don’t mean they are ignoring it or don’t care, they actually can’t tell that everything on the screen is in the incorrect aspect ratio. They can’t see it. Weird. I can also tell, instantly, if I’ve accidentally walked into a movie theatre that’s still using those old 2K digital projectors. So, so blurry.

I’ve tried everything I can think of to test if the problem with PP<->Motion Smoothing is on my end, short of swapping in a completely clean boot drive for testing purposes. I suppose, maybe, it’s a three-way incompatibility between current Nvidia drivers and PP+Motion smoothing. That’s getting really hard to test for at that point though.

Definitely was not an issue with earlier versions of Pitool, but realistically several things have been upgraded in relatively short order. Still, everything else works just like it should, it’s just those two setting, when applied together, that create the issue (hence my initial thought that it’s a Pitool issue).

I too, tend to notice artifacts that don’t bother others, like TV aspect ratio or aliasing. Motion Smoothing bothers me too, at least in the games I play, so I turn it off. In your situation, you need to find a solution you can live with (until it gets fixed). My suggestion would be to try using Normal FOV, instead of Wide, or lower some other settings which don’t bother you as much.

The FSR mod works really well in Skyrim - on the github they even have some very nice side by side images you can compare.

6 Likes

Maybe I’ll give that a try. It will be akin to the way I’m currently playing Cyberpunk 2077; on my 1080p 3D display using SuperDepth3D I’m upscaling whatever DLSS “Quality” mode is actually rendering at to 2560x1440, which is then downsampling back to my 1080p display. Sounds insane but it gives much better quality than spitting 1080p directly to the display.

I was eventually able to get used to motion smoothing. At first it made slightly ill (TVs set to produce fake frames - a large part of what’s known as ‘the soap opera effect’ will also do this to me). It took me a long time, but I eventually trained myself to be able to play games with motion smoothing on. I will say that I like the way vorpX handles motion-smoothing the best. It’s very brute force I think; no blurring or smearing. I think it simply doubles exactly what was in the prior frame or something. The result is that it works really well in most situations but causes a distinct ‘ghosting’ on fast rotation. Still, way better than the queasy-making motion smoothing that SteamVR and Pimax use, IMHO. No weird bits of images distorting or anything like that.

I pounded away at this problem again today for a while, and it’s also not the FPSVR overlay causing it, or an ENB or any settings in the Nvidia control panel (set Skyrim VR back to defaults). It also happens no matter which form of SS I choose; Pitool, in-game, or Steam SS values; so it’s not a conflict with a particular form of Super Sampling. I’m very curious to know if anyone else has this problem. If so, I’ll stop trying to solve it on my end! It’s easy to reproduce. Set Wide FOV and then set PP and motion smoothing ON. Then just choose a Steam SS for Skyrim VR that’s right on the edge of 90fps (or 72 or whatever your refresh is), so that you can easily move about and watch your frame rate throb between 90 and 45. You should see a massive quality difference in Skyrim VR if you are getting the same problem I am. It should immediately sharpen up when you hit 90fps, and then look like you’ve suddenly put on an original Oculus Rift when you switch to 45fps.

1 Like

Sorry, this is completely off-topic. Feel free to skip it. :grin:

Yeah, it sounds about as insane as what I’m currently doing. I’m playing the newly re-released Quake (enhanced) on my 4K flat screen, with all the quality settings at max, but at 8K DSR mode, downsampled back to 4K (at a solid 60 fps with vsync on). Quake has never looked so good. I actually bought my first “accelerated” video card (a Rendition Vérité 1000) to play Quake, since my computer struggled to reach 320x240 res at a “playable” 20-40 fps.

It’s been a kick, replaying the game that got me hooked on 3D graphics.

I did try playing Quake in VR. It’s completely playable, but the scale is massively off (way too big). It’s not VR; it’s the game itself. On a flat screen it’s harder to notice, until you pay close attention to the doorways, which are about 16 feet (5m) tall. Anyway, the VR experience isn’t any good for me (for this game), but I’m really enjoying replaying it (yet again).

1 Like

i recently had to reinstall my windows unfortunetly so i dont have pitool version 270 do you still have this on youre google drive? Grtz

1 Like

Will have a pitool 270 for download in his pimax repo

2 Likes

Thank you verry much :wink:

2 Likes

If I wanted to do a complete uninstall of all (v271) Pimax files, and then clean install, could someone point out exactly which directories to make sure I manually uninstall after I run the uninstall process through Win10 the normal way?

I finally got my Index controllers and Half Life Alyx, and that game won’t even start completely in Wide FOV for me; I get stuck at the grey concrete loading screen. Boy does it run well in Normal FOV, even with PP however. 200% Steam SS, 90fps, and around 75% GPU usage. I haven’t tried any of the “play Alyx without PP” tips yet, and may not bother. It looks like it performs plenty well with PP on. I would, however, like to get Wide FOV working in this title.

Seems like a good place to start is completely uninstalling 271 and going with a clean install. Who knows, maybe it’ll take care of my Skyrim VR issue as well.

2 Likes

PP is not needed for HL:Alyx.

Start it with these steamvr launch options: (discovered by members of this forum)
-console -vconsole +sc_no_cull 1 +vr_shadow_map_culling 0 +vr_multiview_instancing 0 +volume_fog_enable_stereo 0

7 Likes

Yes, I had seen that but not bothered with it since performance was already so good. But, you know what, this FIXED the issues I was having with Alyx being stuck at the initial grey loading screen if I tried to use Wide FOV.

Don’t know if that issue was specific to 271, and just me, or not. Still looking for any tips as to exactly which directories to manually delete after doing an automatic uninstall of 271? so I can go completely back to a fresh PiTool installation?

3 Likes

I got an 8KX again and have a 3090FE on latest Nvidia Drivers. Should I install 271 or 270 then?

I’d like to try 90Hz mode as well.

Good question. I installed 271 to get 90Hz (with the included firmware), but had to go back to 270 because my 8KX kept being disconnected. However, 270 allows me to still use 90Hz, which is apparently controlled by the firmware itself. Older firmware won’t automatically flash over newer firmware. (You can still overwrite it if you need to, but you have to manually upload it.)

4 Likes

I have a question about Fallout 4 VR that I posted in the Game On thread, but realized it’s probably more specific to later version of PiTool. Here is the original question if anyone wants to answer it: Fallout 4 VR Still Working or Not? It’s in regards to a note on the Pimax Games Compatibility Spreadsheet that states that as of PiTool v129 (so a very old notation) that even with PP on shadows do not appear correct in one eye. I’m trying to find out if that’s accurate or not as I’m so sensitive to issues like those that even if it’s minor I probably won’t be enjoy the title. Otherwise I plan to invest in it and mod it (probably with the wabbajack mod list).

Other quick notes: Performance on the 3080Ti (mine is factory overclocked and typically runs just over 2GHz. It’s also roughly the size of a barge) is excellent. I do think that when the NEXT generation of cards comes out we will probably see enough power to drive wide FOV with PP on in the majority of (current) titles and SS settings high enough to also produce clarity. I haven’t used any PiTool version other than 271 since I got the 3080Ti, so I can’t compare performance with other versions).

I also added a note to the Compatibility Guide about Assetto Corsa: Turning on FFR dramatically reduces performance in that title for me. I’ve only noticed that with 271, I don’t recall it being an issue with 254(?). Regardless, you would have to have a really old GPU not to be able to run that title well, as it performs incredibly well and does not require PP, so FFR really isn’t needed anyway.