Pitool Hangs (Freezes) since last Windows update 2 days ago (June 10) - Solved by disabling Nahimic Service

Anybody else experiencing this since a recent Windows 10 update?

It initially works then just hangs while trying to switch options or after turning the HMD off. I then have to force close Pitool. The HMD works without any issues.

I tried to re-install but no luck. Samething with 260.

2 Likes

After about 12 hours of work trying all kind of things including testing hardware (Did 3 different RAM tests), I found out that the cause was the Nahimic Service. This is a software provided by ASUS (and others like MSI) that automatically installs itself with the Realtek audio drivers. Searching a bit after my finding showed that a lot of people have problems with this software. Anyway. This is a lot of time I could have used to race in Automobilista 2 or spend with the family…

It seems almost impossible to uninstall this without losing the sound control panel so I disabled it using SYSEDIT:

image

4 Likes

Thanks for the tip! Oddly, I have an ASUS motherboard and Realtek drivers, but Nahimic is not installed. It sounds like that’s a good thing.

3 Likes

I’m a big fan of ASUS’ hardware but it seems they’ve got a theme going with their software… :grin:

https://community.openmr.ai/search?context=topic&context_id=28515&q=Asus%20aura&skip_context=true

1 Like