PiTool Later than .144 stutter/judder potential fix

hi all,

So i think i may have stumbled upon a fix for the stutter/judder some of us are experiancing with PiTool versions later than .144. Basically setting the pi_server service to run in compatibility mode for windows 8 within the properties has completly removed the stutter/judder. I’ve done a fair bit of testing and can reintroduce the stutter and clear it by doing this.

Hope that helps anyone suffering with this problem. I’m over the moon i can now order an 8KX without worrying that this will be an issue!! :slight_smile:

12 Likes

R
Thanks for sharing! I will try soon :+1:

2 Likes

I’ll die laughing if this works. Thanks for sharing, excited to try this tonight

4 Likes

Might be something to look into @PimaxQuorra in relation to:

4 Likes

So i’ve done an hour session in iracing and zero judder/stutter. I’ve done the above to all pimax services (4 total) and it’s running better than ever.

For reference i’m using the latest Nvidia drivers, Beta SteamVR and Pitool on the following system.

9600k @5.1, 32gb 3200Mhz, 2080, Win 10 (1903)

HTH

3 Likes

Does this just pertain to windows 8, or windows 10 as well? I have expierenced this same judder with the new pitool versions and iracing. Obviously will be teying

It looks like in Windows 10 they are using compatibility wizard setting to run as Windows 8.

I have tried this also and have not experienced the stutter/judder. When I start Steam VR it says I need to update but I just dismiss the popup and proceed as normal.

3 Likes

This is not working for me, assuming that the stutter I see is what’s described here.

1 Like

Does it also seem that some of the newer versions of pitool have hurt frame rate? I have a hard time sustaining 90fps in iracing with any version newer than 144. If I roll back to 132 it cures my issues. However that version doesn’t have motion compensation. :thinking:

1 Like

I don’t get how Pimax can’t determine the cause of this stutter if version 132 was OK and things got bad after that. Way too many titles have this problem for me. Just slowly moving my head back and forth in a relatively low complexity scene will cause a jump.

1 Like

Hi DrWilken,

Thanks for tagging. Will go into that post.

Sincerely,
Quorra.Pimax

3 Likes

Noticed all the posts in that link are RTX cards.

3 Likes

It happens with my 1080 as well unfortunately :frowning:

4 Likes

i have rtx2080ti but never has judder or stutter… however, I applied this setting. Just in case :smiley:
PS: using win10 LTSC/LTSB all the way.

3 Likes

I’m using a 1080 as well.

So i was getting a head movement judder when looking left to right or up and down as well as a stutter when going round corners with my head held in a static position.

Not working for me. Rtx 2080ti, i7 9700K, 32mb ram. Windows Pro 64bit.

I hadn’t been running fpsVR for a bit so not sure when this started (after pt180 for sure), but it seems Smart Smoothing is engaging even though not selected. Framerates drop to half even when only losing a very few from max.
I can maintain 72 fps in Assetto and if I go under by 2 or 3 fps for even a second, it goes to 36 fps and stays there. This is happening in other games as well.
It seems to have begun after the first time I tried Small@ 120 Hz which when running Dirt Rally 2 at modest settings, I was hitting 112 fps and Smooth still engaged and dropped to 60.
I seems like the Smooth tickbox is non functional.

1 Like

CPU: i7 7700k
RAM: 16GB @ 3000/15
GPU: 1070 non TI
Headset: Pimax 5K+ 203…
Pitool: V1.0.1.249
Firmware: V2.1.255 .255
Nvidia: 441.41 Driver
Tracking: 3Dof (no Station)
Windows10

I had bad stutter/judder using Pitool .180/.197/.245/.249
Even with ultra Low resolution and non GPU demanding Games.
Only Pitool .132 and .144 worked without stutter/judder and Hi resolution.

Anyway, running Pitool .249 and overwrite both pi_server.exe + Pitool.exe at Compatibility mode for Win8, the stutter/judder is gone!
I´ve tested it with Project Cars 2, DCS, Skyrim VR… no stutter/judder anymore!

Also i have to say, the stutter/judder problem should have been solved by Pimax within 2-3 Days via Hot Fix! But still untill today nothing happened!

I´ve payed a lot of money for the Pimax 5k+ but getting handled like that makes me realy affraid to buy another product by Pimax, sorry.

3 Likes