Pitools 271 screwing up my computer

I’m having several issues with 271:

  1. It seems cause USB issues, repetitively connecting and disconnecting something and eventually causing a VR fail where the program hangs with a ‘waiting for (software/game) message.
  2. It seems to hijack my audio out to the 8KX speakers, even though I select my focusright audio interface in sound settings. I have to close pitools to get my audio back.
    Anyone else having these issues?
    I’m going to roll back my pitools version.
    Cheers
    Finn

Hello Finn,

Could you please file this issue to our tech team, and describe more about these 2 issue in the ticket, so they could recreate the situation or provide any related solution.

Did the (1) issue happen once you updated to 271 version? And with the latest SteamVR ?

Regards.

yeah since i installed 271 it crashes steamvr and it doesnt matter if i use steamvr beta or the current

I fixed the issue, the problem was a overlay app that i disable on launch.

Hi,
I’m not convinced it’s connected to pitools 271 yet. The problem got so severe that I wound up doing a reinstall of windows 10. I’m now testing to see if the problem continues with 271 and if so, will it go away when I roll back to pitools’ previous iteration? Because it manifests itself as a USB connect issues, with something in the USB chain connecting and disconnecting repeatedly and in rapid succession, it could also be some sort of hardware issue. It does look like it only happens in VR, but I’m still working on the reinstall of windows and all my software, so I’ll need some time to test more.
cheers
finn

1 Like

Hello,

Appreciate that, please let us know after the further test.
And will suggest you to file this issue with the technician, so they can provide further assistance.

If the problem continues with 271, you can try to roll back to previous version, and run few tests on it.

Regards