Playing Asgard's Wrath In The Pimax 5K+

Cool… glad it is working well for you too! []-)

What a lovely VR treat. Except for the slightly clunky pads for movement, this game actually handles really well on wands. Especially the menus.
Graphics are awesome. Way better on the wide fov for sure.

1 Like

Yeah my thoughts exactly… I was actually amazed at how well it worked with the VIVE Wands!


I tested the game yesterday with the Pimax 5k.

With Revive, it’s actually not good, I’ll agree with you.

That’s because of Revive!
Turn off Steam completely and start the game over Pitool then it runs smoothly. I even have the feeling that the graphic shepherd is with Pitool.

However, Pitool needs to be updated for this game.

The game is quite smooth, but the menu button does not work with Pitool. So we can not get into the inventory.

Also, sometimes the shadow in the right eye of the Pimax is not always displayed correctly. Sometimes the right eye flickers briefly.

It is not always. But it can happen.

Pitool needs to be updated for the game.

Songs SweViver

PLEASE pass that on to Pimax.

The game is great. We need one. Pitool update for these games.


Internally, most likely. They recently announced 120Hz mode for the 5K+ in an upcoming release… There’s probably other goodies in that release since it’s been a while… :wink:


You can get into the menu when you are pressing both touchpads
simultaneously :wink: I tested it on the valve index controllers using only the pi tool :slight_smile:


Hi , nice to see the game is getting attention,
@VoodooDE also posted some videos about it, looks great!

I cant wait to get my Basestations and then I guess I will pick up the Index Controllers to go along with it - its been a long time since I got to go for a Room Scale game - that one looks like a lot of fun.
How are the experiences so far with a setup like that (5k+, 8k’x) and the index controllers?

Here the other Videos:

Gameplay Comparison, also already with the 8k+

Edit: VooDooDE ran it with revive, @VoodooDE have you tried it via direct PiMax call up?


Did you still buy it via occuls store or is there a plan that it will come some where else on sale also?
(Would prefer Steam or gog or something more common for a non occuluser)

Edit: So would it work with 5k+ and the Index Controllers?

@PimaxUSA and @Matthew.Xu could you pass this on to the team for pitool opimistion?
Its a great looking game and would add niceley to the PiMax Library if it runs, especially with the 8kx upcoming! (@SweViver )
Thank you!


Yepp, Ocuklus Store, i think it´s an exclusive and won´t come elsewhere…?

I´m using 5K+ with vive wands, don´t have Index Controlers.

1 Like

It works perfectly fine with my pimax xr oled and valve index controllers . I am playing via pi tool software . Simply buy the game in the oculus store and import it via the pi tool game library software and you are good to go . DONT USE REVIVE since its gonna break your performance if you use a pimax headset


Yep. Oculus exclusive. Could come to Steam later but no guarantees. Lone Echo hasn’t. Oculus store is worth having installed for Pimax owners just for this title, imo.


its strange that defetor still has colour problems and asgards wrath runs totally fine . Player height is also perfeclty fine compared to defector. I remember that lone echo also had issues with colours with an old pi tool version , so I hope that thy will fix it in the upcoming no beta pi tool software

Am I only one experiencing flickering in loading screens?
Also joystick emulation feels pretty bad when moving with vive wands.

5K+, 1080TI, pitool version 180, Epic graphics, ingame SS 0.25, no revive.


Menu button worked fine for me playing from Pitool? Pretty sure you have to long press it!


I also experienced flickering in the loading screens but since it did not affect the gameplay at all I failed to mention this in the video… sorry about that!


Aha. Got it.
However flickering bothers me a lot since I am not a native English speaker. Can’t read all the texts in time…

What about joystick emulation through trackpad? Does it work well with you?

Thanks @RaiN274, I will do that!

How did you import it into PiTool or Better what Part /EXE ?
I tried the
WrathGame.exe and the WrathGame-Win64-Shipping.exe
with in …“Occulus\Software\sanzaru-games-inc-wrath\WindowsNoEditor”
It sows the Wrath Logo, then the screen turns black and I am back to the desktop - the HMD does nothing.

Did you try reducing the graphics? Some games do that to me then run if i reduce fov and render quality. I haven’t jumped on that title yet so I don’t know. Good luck.:thinking:

1 Like