Playing games with pitool only, without steam vr

I read somewhere that we can play vr games using pitool game laucher only and uninstalling steam vr for better performance anybody knows if and how to do it?

1 Like

It depends on the game.

If the game supports Oculus You can start the game in that mode instead of SteamVR/OpenVR mode.

Here’s an example:

In fact, @park has made a lot of guides:
https://community.openmr.ai/search?q=%40park%20how%20to%20play%20in%3Atitle

Ok thanks do you have to do that for every oculus suported games? and does it improve performance?

I think so, yes.

Only if the game required parallel projections to be on when running in SteamVR mode.

If not, I’d say performance is most likely very similar in both modes (both that might vary between games/game engines?).

1 Like

Thanks alot for your quick reply! I just got my 5k plus for xmas i installed pitool 197 and firmware is 248 i think should i install latest or not ?

2 Likes

I have firmware 244 everything looks good but i have to set ipd to min

1 Like

Hello,
I disabled steamVR in the steam settings so that it is not launched by default
and I have better performance in iRacing and DCS World and also iL-2 and Dirt Rally2

but I don’t know if it works with all games,
to do a test you don’t need to remove steam VR only deactivate it in the parameters of steamVR

1 Like

Great i’m going to try that since i pretty much play the same games plus asseto corsa competizione

1 Like

Hey mate,

Could you please explain better how you did that ? I’m trying to do the same but unfortunately haven’t found yet… :frowning:

Did’nt work for me either tried uninstalling steam vr that did’nt work also

Yes !
In the Steam VR window, go to Settings > Developer and then uncheck, " Start Steam VR when application starts ."
Thats work fine for me

I Play skyrim without steamVR

Oh man… can’t find this option on the last steamVR version :sob::sob::sob:

Anthony je vais essayer de trouver la solution, j’ai vue que la dernière mise à jours à changé les options mais il doit sûrement y avoir une solution et je vais y jeter un oeil pour toi

I am the opposite. I only launch Pitool for Oculus games otherwise I just launch from Steam or independent game launchers (DCS,ED and IL2) and don’t bother launching Pitool at all. That way my fov stays at normal and smart smooth stays off.

after verification I saw that the option is no longer available and I wrote to Steam to find out how to do it with the new SteamVR interface I will get back to you as soon as I have an answer

Thanks a lot DaN67!!! :slight_smile:

1 Like

Question i’m still setting up my new 5k not new to vr i can get very clear image except for my right eye a bit blurry and if i look to the right just a bit it gets very clear i’m at min ipd and software ipd makes no difference it almost feel like the lens is dirty in that spot but its all clean any idea my ipd is 63

Hi Rog :wink:
I noticed that the IPD adjustment of the headset is not the same as our real IPD,
I am at 70mm but I have to adjust the headset to about 5 mm less than my IPD,
in the helmet I am about 65mm to have a clear picture,
the only suggestion I would have is to place the IPD in the software at the lowest which is -5 and try to find your sweetspot by moving the headset gently from left to right and from front to back ,

but if I were you I would communicate with the pimax customer service to understand the real adjustment of the IPD of the Pimax,

sorry for not being able to help you more than that …

1 Like

From Steam,

A number of settings available in the old interface have been moved around a bit until they are finished adding them to the new settings interface.

This option can now be found at SteamVR Menu > Developer > Developer Settings.

Let us know if you have any other questions - we’ll be happy to help!

Steam Support
Jesse

1 Like