Problem starting DCS

I have am error message on DCS start-up regarding transponder exceeding connection time. Any thoughts guys?

1 Like

Hi Mich have you tried a google search on error?

I get the same error. Just click OK on the messages, they will pop up two more times about 30 sec. apart, then the game will start. Have the headset on when it starts so your position in the cockpit will be at the right height.

1 Like

No…does not work…and its only with DCS. Thank you for your reply and hope the devs are working on this.

1 Like

You have to import DCS.exe into the Pitool game section, then click on the imported icon.
After a few sec. the two error messages pop up. Click OK on them, then about 30 sec. later (depending on the speed of your system) the two errors will pop up again, then 30 sec. later they pop up one more time then the game starts. The frames per sec. are higher than running the game with Steam, but with Steam the game starts right away.

1 Like

Thank you for your reply. Eventually it starts afters about 7 pop-ups but then with corrupted graphics unfortunately. Hope devs are reading!

Sounds like you need more of a compare with other DCS users whom have it working.

@SweViver might have some tips.

Make sure parallel projections is unchecked. That worked for me. I’m using the latest pitool and latest Nvidia drivers.


Tried latest 430.86 Nvidia drivers, still no joy, something to do with the compiling shaders. Deleted metashader2 but no luck. This is a problem specific to Pitool short cut launch as the game works perfect otherwise with SteamVR.

Hi, seems to be related with DRM - DCS works but no additional modules available…

1 Like