Replacement 6m Fibre optic cable arrived today, exactly same problem as first

Hi, I posted a few days ago about a DisplayPort issue I was having with my 6m Fibre optic cable. Pimax support were very good shipped me a replacement cable within days, I was quite impressed.

However I have just spent the last 2 hours testing the replacement cable and it has EXACTLY the same issues as the first cable I received. Those issues being 90Hz mode not available and DisplayPort noise/snow on the image in 75Hz & 60Hz.

I have a Gigabyte AORUS RTX 3090 Waterforce WB and talking to a couple of people on reddit that have also had this issue, 1 of them has the exact same GPU as me and another had the RTX 3080 variant of the AORUS cards. So I’m wondering is there a compatibility issue with the AORUS cards or are they more susceptible to DP noise?

I don’t realty see any point in getting endless replacement cables, am I better off sending them back and just trying to extend the existing cable, after all I only need an extra 2m.

Cheers,

1 Like

Hi, same issue here with exactly the same graphics card

2 Likes

Difficult to say. But yes it might indeed be easier to extend the og cable as it seems like it is more stable and better shielded maybe.

Only thing I can think of with the Fiber Op cable that maybe a shielded booster may help or that maybe it is receiving interference from the USB part of the cable.

However if it is Gigabyte Cards might be something in there design. Difficult to say.

Can you provide a link to a shielded booster?

That 4 people, knew i should have gone ASUS

1 Like

TBH I imagine most Boosters are shielded in some way. You would want to see what others have tried and found worked. I have no direct xp with attempting to extend/boost cables with pimax hmds. Sometime tomorrow will try a search as I recall a few ppl had posted a variety of cables and iirc some cables may have had built in booster.

I have 3080 Ti and my optic cable works “almost good”.

Well 90Hz don’t work, but I’m OK with 75Hz (thinner and lighter optic cable mounted to ceiling much better then standard 4m cable on the floor).
Snow issue… Some DP port slots of my video card have that issue, but some slots haven’t. After i re-plugged HMD to that slot the issue has almost gone. And after i replugged power USB cable to one of the USB slots (had to experiment a bit) the “snow issue” totally gone.
Sometimes even at this “good slots” snow issue reappear, but if i unplug and carefully plug in, the issue is gone.

First i plug in DP cable, and only then power USB. To switch off, i first unplug power USB cable and later DP cable. Hope it helps.

Which brand of 3080ti do you have mate?

1 Like

Here is a link to @DrWilken topic on Extensions. He would be a good resource to ask

2 Likes

@Heliosurge would you recommend i contact support and send the Pimax cables back? If they send me more cables im pretty sure they are just going to all be the same and id rather not waste everybodies time.

Might be an idea as not sure tbh on why a supposed higher quality cable is failing to at least match performance of the og copper cable.

If your willing to take a gamble you might be able to improve it with one of the repeaters/boosters and a short short dp cable but not sure.

@Heliosurge That is an idea. But if i buy a repeater and extend my cable then I don’t really the Pimax cable and i could have saved myself £150 :-/

1 Like

Very true which is curious why the Optic Cable wasn’t tested longer to ensure it has strong wide capability/compatibility as in theory it should improve stability on low powered things like Laptops and it seems it does nit deliver.

Thinking of ordering these. The lindy repeater seems to get priase in that thread, not sure about the cable though. I’ve message the OP hopefully he can advise :slight_smile:

https://www.amazon.co.uk/gp/product/B086WWJ6KF/ref=ox_sc_act_title_1?smid=A30DC7701CXIBH&psc=1
https://www.amazon.co.uk/dp/B012VLKMBW/ref=twister_B07T93YDX8?_encoding=UTF8&th=1

3 Likes

I use this repeater…https://www.amazon.com/dp/B086WWJ6KF?psc=1&ref=ppx_yo2ov_dt_b_product_details

and this cable…https://www.amazon.com/gp/product/B07HL7RSRW/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

with a 3090 Ti and the 8KX standard cable mounted to the ceiling.

2 Likes

I didnt personally have a problem with the fiber cable, but adding a an active repeater with 3 foot extension killed signal for me. The fiber works fine unextended but I have a different GPU brand (3090) …i wonder if all fiber cables sent by them are not created equal as they probably dont have a one and only maker…

1 Like

As reported in another thread on this forum, my setup with this exact same issue is also an Aorus card (3080 Ti.) I don’t remember the specific model but could look it up if needed. Works perfectly with the original cable, and displays snow at 60hz and 75hz with the optical cable, along with no signal 90hz. I had a 3090 Ti at one point, which did not work at all with my HMD, but I did not have it at the same time as the optical cable, so I was unable to test swapping out the cable while I had the 3090 Ti. Due to the costs, I returned the 3090 Ti and the Optical cable, so I no longer have anything to test, but hopefully one more data-point that this seems to be impacting Aorus cards will be of some use.

1 Like

@mr_spongeworthy did you test all the dp ports on your aorus card? The middle port on mine was by far the best and had less noise/issues.

1 Like

I did try all the ports with no luck.

1 Like