Resizable BAR (and AMD SAM?) is causing Smart Smoothing glitches, ghosting, doubling

Hello, this is public service announcement kind of post.

Last night I’ve decided to fly a little in VR (Pimax 5K+), since it’s been quite a while. I decided to play some DCS and IL2. However, I’ve discovered an issue in both titles when Smart Smoothing was enabled. The image was either constantly glitching/ghosting/doubling in DCS and behaved similarly in IL2 but only occasionally, when there was a little bit more action on the screen.

I’ve tried a bunch of things to troubleshoot. No matter the graphical settings, CPU or GPU utilisation, as soon as FPS dropped into Smart Smoothing territory (in my case below 120hz) the glitching was everywhere.

I have a pretty decent hardware - i9 10900K (OC 5.2GHz, HT off), RTX 3080 (also OC) and 32GB (3800 cl14).

As mentioned above, fpsVR showed that in both cases there was a pretty decent room to spare and no spikes and yet IL2 case seemed to indicate I was CPU limited.

Suddenly I remembered that few months ago I installed a new BIOS for my motherboard to use some of that free performance (in some games) by utilising resizable BAR. I’ve also remembered that in some other cases it may actually cause performance loss.

I went straight to BIOS, disabled the bastard and et viola! No more glitches! Everything super smooth in both games. To be fair BIOS I’ve installed is a beta version and I will be upgrading to more recent “stable” version today.

Perhaps it’d be good to make this thread sticky, since this is not an obvious solution (at least wasn’t for me) and it may be actually useful for others in the same boat. Perhaps someone can test whether the same issue exist on AMD platform? My understanding is that SAM/resizable BAR is enabled there by default?

I’ll post the same thing at r/Pimax.

6 Likes

Your description is not quite the same for me
i am AMD, Iwill try no sam and see.

1 Like

Just from the other side:

Did anyone notice any benefit from turning on RBar / SAM for VR and Pimax 5K/8K especially?

Due to all published benchmarks in WQHD and 4K/UHD, I doubt about it, but did not try it so far.

How did turning off SAM work out for you?

Did you reable re-size bar with the new Bios? I recently updated my Bios to see if it would fix sutters but to no avail.

How did turning off SAM work out for you?

sorry, not tried yet.

I haven’t updated the BIOS yet. Can’t be bothered right now, since I’m not playing anything that’d take advantage of r-BAR :stuck_out_tongue:

I did last night, didn’t make any difference for me.