[ Resolved - USB port issue ] Half-Life Alyx crashing every few minutes

Intel 7700k, 16GB of ram, Nvidia 2080ti, pimax 5k+

I initially get a “low GPU memory” error once the menu first comes up upon loading, which is surprising with a card with 11GB and nothing else running in the background. Although I’ve talked to other people that get this with no issues.

Every few minutes the game and steam VR completely crash. I get no errors at all. No other games cause this. Otherwise the game runs pretty good, just some stuttering here and there.

I have the latest drivers, nothing else running in the background, verified game integrity, I’ve tried disabling nvidia overlay and messed with a variety of settings in pitool, nothing helps and I don’t see any pattern in-game to what causes it.

1 Like

Try checking the file integrity via Steam.

1 Like

Haha thanks but, I did say I tried that.

1 Like

what firmware & pitool version

I have the latest pitool ( and firmware (

Also tried again today after the most recent Alyx update that included crash fixes but it didn’t fix my problem either. Tried Steam VR beta too, no help there.

I had this because my Windows swap file was set too low (4096). I set let Windows handle it and all been good since. Others have reported 16384 size works.

1 Like

Latest pitool is 258

I switched the USB port my headset is hooked up to and then Alyx stopped crashing. I can’t confirm whether or not switching is what actually helped but it’s worth a shot.

Valve Index users are also reporting crashing on Steam so it’s not just us at least.

Huh, does pitool’s update function not work at all? If I check for updates inside the tool then it just says I have the latest versions. The website currently lists 255, https://www.pimax.com/pages/pitool huh.

Does the firmware update have the same issue? Should I be checking firmware some other way?


Yes I noticed this too, so it’s not just you. I’m pretty sure my Pitool is old - does anyone know if this is a 'feature '?

btw I played on my 8k with pitool 258 yesterday for about 40 minutes and didn’t experience any crashes. Was pretty solid experience

1 Like

Looks like currently, the only way to know if new pitool is out is to follow these forums.

1 Like

Where to even get 258 then if 255 if the latest they have on their website?

Jeeze Pimax, it shouldn’t be this weird to get the latest update lol. Why even have an updater in the software if it doesn’t work.

I’ll be trying again tonight as well as monitoring my vram usage and maybe running with lower settings for a while.

Here ya go.

1 Like

Yup updating to 258 pitool fixed my crashing. What the heck. Could’ve saved a lot of troubleshooting time if I had known their in-app updater was worthless.

So I guess I still have questions, does pitool’s firmware updater have the same issue?

And where can I check to always make sure I have the latest pitool? Since their website is 3 versions behind too…

1 Like

PiTool seems to only check for “final” releases. All of the recent versions were betas or alphas, so they haven’t been well-tested and have bugs and missing features (like a backlight brightness setting).

1 Like

My PiTool is V1.0.1.121 and when I press ‘Check Version’ it says ‘Your PiTool is already the latest version!’

Does anyone know if V1.0.1.121 is the last ‘final’ release? Thanks

That doesn’t even really seem to be the case, unless Pitool’s main download link is on some other release schedule too, because I had 249 and it told me I had the latest version, and as of couple days ago the website downloaded 255, even though the latest “beta” was 258. I noticed that a few months ago too that the updater in-app said I had the latest version but was actually wayyyy behind what was on the website.

As of today the website just provided a totally new version, 2020.3.24, which seems to go off dates now instead of version numbers. It also added a tab for “Alyx”


Never mind, my problem had nothing to do with the software. It was actually the USB port. I tried another USB port and the crashing completely stopped.


It only works when “stable” firmware is released.

so it’s working perfectly.

(…it will never work again)