Smart Smoothing doesn't work on AMD Radeon 6900XT

Date: January 17, 2022
Issue Title: Smart Smoothing doesn’t work on AMD Radeon 6900XT
Description: I upgraded from an nVidia RTX 3070 to an AMD Radeon 6900XT. On the 3070 Smart Smoothing was perfect, but on the 6900XT there are severe artifacts, which get worse the more it is needed. In Flight Simulator 2020, for example, it is so bad overlapping images are flickering between the two eyes, which makes people feel sick. Nothing else about the system changed but the GPU. Disable Smart Smoothing, no problem at all


HMD Model: 8KX
First 3 Numbers Serial: 207
Pitool Version: 274
HMD Firmware: 2.1.255.299
Tracking: Lighthouse 1.0 x 2


System Info

  • Windows Version: 11
  • CPU: AMD Ryzen 5 5600X
  • RAM: 32GB
  • Motherboard: ASRock B570
  • GPU Model: AMD Radeon 6900XT
  • GPU Driver: Adrenalin 21.30.23.03 (December 1, 2021)
  • SteamVR Version: 1.21.6 (Steam Motion Smoothing disabled)
  • Oculus Version:

Attachments (Pics/Video etc…)

3 Likes

@Dreamwriter Yes, I have said this before.

There is something wrong with the SmartSmoothing. Probably related to the AMD 6900XT.
Currently I leave it SS off and set so I can hit 90 FPS all the time.

Pitool Beta v1.0.1.271 Discussion

I can confirm AMD 6900XT @ 90hz 90 FPS on 8Kx is working, and has been for weeks.
Look great! feels great!

It is not all good. There is a problem (double vision) with SS and if I drop below Hz then I get double vision (in each eye).
e.g. 90hz hit 85fps or 75Hz hit 70fps
It is like having two pictures on top of each other, off set.
i.e. The original image and the fill in replacement image on screen at the same time and not aligned. This is in either eye, or both or one at a time.
Two tickets written, pimax seam to be ignoring it.

But if i hit fps, wow great.

1 Like

I just updated
HMD 8KX
Serial: 207
Pitool: 1.0.1.274
Firmware: 2.1.255.299
Lighthouses 2.0 x2

System:
Win 10
CPU: AMD Ryzen 9 5900X
Ram: 32Gb
Motherboard: TUF Gaming X570 PLUS WiFi
GPU: AMD Radeon RX 6900xt
GPU Driver Adrenalin 21.12.1 (pitool says: 30.0.14011.3017)
SteamVR: 1.20.4

I think there are two things happening:

  1. SmartSmooth Very high settings - so GPU can not keep up
    Bad wobble, not symmetrical. lines bending and then returning to where they should be.

  2. Compulsive smooth - GPU can keep up, but is working at 1/2 or 1/3
    Double Vision in each eye. Exactly as I reported [quote=“Darrell, post:1, topic:35751”]
    Double Vision explanation
    [/quote]
    When I move my head, I the picture is doubled and the two pictures move away from each other. They move away more, the faster i move my head. When i stop moving my head, they return to being aligned or one picture.

EDIT: new pimax support ticket #23355 19 jan 2021

I haven’t used PT Smart Smoothing in a very long time. i find MSFS2020 and pretty much everything else runs great on SVR Smooth and 144 Hz. None of the artifacts i would get in titles like DCS.
Can’t speak to AMD but pleased on Nvidia . Indeed 144 Hz is smoother than any other setting at the same fps in my experience.

The problem is people who are really pushing their systems need Pimax Smart-Smoothing. Meaning, anyone using a Pimax 8KX at anywhere near native resolution, 4k per eye. For those of us, we need to set the headset to as low a refresh-rate as possible, then use Smart Smoothing so our computers only have to render at half that framerate, letting SmartSmoothing interpolate the frames to double them back up, resulting in a buttery-smooth VR experience.

When using my RTX 3070 with my 8K+, it allowed me to adjust Flight Sim’s settings to barely get 36fps, which SS would then double to 72fps, to match the headset refresh. Now I have a Pimax 8KX, which has a higher resolution (and a 60hz refresh mode), so my 3070 wasn’t good enough - it still worked, and SmartSmoothing still worked, but it was really hard to get 30fps with decent settings to allow SmartSmoothing to do its job.

So I upgraded to a 6900XT, which does really seem like it can run the game at 30fps at 4k-per-eye and decent settings. Except, Pimax Smart Smoothing, which would normally double that to 60hz, is apparently unusable on AMD cards. And 30fps makes for a bad VR experience.

Thus this bug report. Hopefully Pimax is working on the AMD smoothing issue.

1 Like

I had not found SVR’s Smooth to be any less efficient in frame duplication than Pimax’s solution.Only less artifacts. Are you saying the 8KX doesn’t works as well with SVR’s method?
Does SVR Smooth work with the 6900?

Reply from Pimax ticket:23355

" Hi Darrell,

  1. When you turn on SmartSmooth, there will indeed be some problems. This is related to the performance of your graphics card. I am really sorry.

  2. If the frame rate of the game you are using is unstable, then you can turn on the Compulsive smooth function, it will lock your game frame rate. For example, if you play Half-Life, the game will have 90 frames, and different scenes will have different frame rates. When you turn on 1/2 of this function, it will lock your frame rate at 45 frames. But a drop in frame rate can lead to issues such as ghosting. So far, both of these functions have been designed to provide smooth gameplay, but they are not perfect, we recommend that you turn on Compulsive smooth first, then SmartSmooth.

Note: Should you feel that you are currently not receiving the expected level of support from the agent or if you believe that an extra pair of eyes on your request would hasten the resolution, please click here to Escalate

Best regards

Adonis
"

My response:
Dear Adonis,
Thank you for your reply.

You have not understood my issue!

Did you watch the video given to your staff thought Wechat?

You have completely ignored my second point about Compulsive smooth.

Is your intention to fix the issue or make me stop complaining?

SteamVR motion smoothing is different. That watches for frame drops, and if it detects them, it uses motion data from the previous two frames to delay the second frame and add an extra one in the middle. Pimax motion smoothing (when it works) also looks for frame drops, but when it detects them it then locks the render rate at half the headset refresh rate, so the GPU only needs to render half the frames, and then interpolates the rest of the frames. It can do that on the driver level, and results in a much smoother, more consistent render, as long as you can maintain that half framerate.

8KX needs much more smoothing than the 5k+ or 8k+ because it’s rendering more than double the pixels (and Flight Sim requires a monster computer to even render in plain old 2D 4k, let alone VR with parallel projections)

Very informative. And I have read something like that here (OpenMR) before.

I am not using Steam Motion smoothing or Pimax Smart Smoothing, or Pimax Compulsive Smoothing; because they do not work.

The point of the thread here is to
1 Let Pimax, and others, know, and
2 See if we can get it fixed!

Yes, I am using one, and so are you.

SVR uses both Smooth and legacy re projection. When running at 144 in MSFS and only actually getting fps in the 30s my frame rate is quite smooth.
It is actually better than running 72Hz and 30s fps.

In any case I never found Pimax’s method worked all the time. DCS had particularly bad artifacts where SVR almost none.

1 Like

Never really tried, seam to remember it did not work.
Just for you, I just tried.
It does not work. It has double vision. Almost the same as the Pi Smart Smoothing (i need to be careful with acronyms - Pi SS). At least on WFOV.
Now, is that the 6900XT or ?

No. Well not useable.

1 Like

Ya got lazy since it’s in the thread title i figured that would be understood.

I run SVR smooth on all my sims and many demanding titles since I only have a 1080ti and every game works with it.
Sounds like an issue with Pimax and/or. AMD

1 Like

This has been an issue for a long while now. I was talking to Pimax support about this back in October or November. They added the Compulsive Smoothing feature when I while I had ticket open with them, they told me they added it. That feature helps but definitely not the same as actual “Smart Smoothing”. I have a 6700XT with a 5K Super and their Smart Smoothing feature just doesn’t work on AMD GPUs unfortunately. I borrowed a friend’s 2070 Super to test while I was talking to Pimax support and Smart Smoothing worked perfectly fine with that GPU.

I just think it’s because Pimax doesn’t have an AMD GPU to test because when I talked to support they seemed to be not aware for the issue at all, I had to get them video of it. They had me doing a lot of testing actually but didn’t mind, just want them to get their software work well on AMD GPUs because their no real reason why this feature shouldn’t work. I had a 5700XT and a Vive before this and Motion Smoothing worked just fine in Steam VR so I’m thinking it is a similar function.

1 Like

In the last year, I have opened a few tickets about this issue. The last one was from a request from them. Found me here, looked up my personal contact and asked me to make a ticket (mainly because i am in China with a 6900XT);
#23355 Pitool 274 Smart Smoothing & Compulsive smoothing AMD 6900XT

It sounded like pimax wanted to get it into fixing it.

But the reply was a standardised response, looked like they did not read what i had written. Then the follow up was (after they found out they asked me) (left hand not knowing what the right hand is doing) they said “give us some time.”
Then another follow up "Hi Darrell,

Thank you for your understanding, we are enjoying a 7-day vacation here, we will officially resume work on February 7th and test as soon as possible, we apologize for the inconvenience caused."
That was the last message!

I think that means: someone at pimax wants to look into it and fix it. But maybe it is not that easy or other things have priority.
I did get the impression: they asked me because they did not have an AMD card, at their office, to work with.

1 Like

Yeah exactly what I experienced with them. I’ve sent a few tickets and eventually I started getting the same support person for each ticket I sent so conversations have been smoother but still end the same as you’ve said. Most recently I’ve gotten the response that their team it going to be working on the issue but maybe be slow to fix because they are hard at work on new product (assume the 12K). I do like though that their support team get back to you quickly and at least try the best they can to help, they might just need more people.

But commenting on the GPU issue, if it’s true that the reason why AMD GPUs can’t use all the performance optimization feature on Pimax HMDs is because they just don’t have one to do testing with then someone needs to get them some! lol. If some how we can get AMD to send them some RDNA2 GPUs that would be amazing. It’s unfortunate though because I do like Pimax HMD hardware and it’s great but if AMD GPU support is going to continue to be poor (also Pitools and VR Experience Home don’t have cohesion between each other, as well as other bugs) then I might have to start looking at other options. Was really interested in the Pimax 12K but I don’t know if I could buy one if the software experience has not been completely overhauled.

1 Like

Yesterday, after my post here, i pinged my ticket with “any update?”
"Hi Darrell,

​Sorry for the inconvenience. Due to the coronavirus, we are currently in quarantine and cannot perform any tests. We will email you if there are any updates, thank you for your patience."

I am in China and we just had a 3 day small area lock down, and testing every day. Requiring a green code with a 24 hour clear test to go anywhere (like go to work). So i can see that as an issue. China is good at this.

I am having a great time with my 8Kx and AMD 6900xt. It is SO good. I love it. Great (and a lot more positive superlatives). This combination is very useable, right now. There is something about new chip in the very new special 8Kx with an unusual firmware that is not AMD compatible and can not run 75hz or upscale (at the moment). But that is a different thing. My set up is GREAT.

I wanted to say that, to put in perspective the issues i am having with Pimax and AMD. It would be great if they (AMD, Pimax, SteamVR) could fine a way to fix smart smoothing, Steam VR motion smoothing, FFR and or … I would us one or all of them.

Maybe we need to look at openxr toolkit?

AMD just announced RSR (Radeon Super Resolution) a hardware implementation of FSR. That should allow games that do not have FSR implemented to use RSR because we have AMD RDNA cards. This could give us (some of) the boost we are looking for.
I will probably try it this week end. But i should to be water cooling my AMD6900xt GPU. Hmm, which one first?

I have a 5K+ with an 5700XT and now a 6800XT and smart smoothing has never worked for me, i always assumed this buttery smooth talk was bs, but reading this it seems its fine on nvidia. I really hope they address this AMD only issue. Thanks for pushing this case Darrell.

wrt RSR I’m not sure how that will work with VR it seems to be directed to monitor resolution only?? Intrigued if anyone can get that working - I cant find anything on the internet about RSR and VR so far.

1 Like

Hi Mr hogan !

i was desesparate to find a 6800Xt owner with a 5k !
as i have a rx6800XT and plan to buy a 5ks ( but unsure to invest due to info/gossip/bs on the web about various issues with amd gpu)

could you provide me your personal feedback on you experience ? ( fps/fluidity/game you play and if you have tips/tweak/mod like openvr_fsr ) ?

i plan to use 200 Fov mode with 90hz mostly ( hate the tunnel effect of low fov ^^ )

thx in advance

Regards,

Holy

(btw as RSR is avalaible with last amd driver did the update improve perf ? on my side it screw up my triple display settings ^^ , but if it work well, i might look on 8k series)

I think RSR only works with monitor displays? I cant find anyone discussing it with VR.

I only play car racing sims - so I don’t need base stations and the headset bulk doesn’t affect me at all - unlike other more active titles might.

I like to play with high graphics settings so I rarely have enough gpu/cpu grunt to go to the max FOV and keep fps.
I can run “Large” for iRacing, Assetto Corsa and stay above 80fps
I run “Normal” for Assetto Corsa Competizione and Automobolista2 for these titles I get 60-90 fps (depending on track factors).
I use in-built FSR in ACC, I tried openfsr in Automobolista but i preferred native.

So using Large FOV and still achieve 90fps will not be easy, without sacrifices to graphic quality. ACC and AMS run smoothly below 90fps though so you may not need to hit 90fps.

Smart smoothing cannot be used at all atm :frowning:

Fish bowl / warping - I don’t experience this at all - but that might be due to the nature of racing games - you don’t really look in the corners - its really peripheral vision your using your eye is typically focussed dead centre.

Dropping FOV down to small or potato does give a significant boost to fps - i would use small when I had my 5700XT its still 130degrees.

I’ve never used another headset other than a Samsung GearVR so I can’t make direct comparisons with other headsets, but for me and my unique sim only usecase its brilliant.
If smart smoothing gets fixed for AMD then perhaps I could go “Large” and ultra settings in all my games.

1 Like

Pimax has followed up with instructions for taking logs.
So I am working on that.

Updated
BIOS 2022/03/07 Version 4204
AMD Radeon RX 6900XT
Radeon Adrenalin 22.4.1 (released 4/6/2022)
Pitool: V1.01.275
Headset Firmware: 2.1.255.299
SteamVR 1.21.12

Smart smoothing has changed. It is still two pictures (my guess is one original and one fill in). But now the two pictures are much farther apart.

Hold my head still = looks great
Move my head = two images (in each eye). Good, clean images. On top of each other. One where the image should be, and one where it was. The distance between them changes as the fps catches up to where my head is. Until, I stop moving my head, they both line up again.

I can not show a photo or video, as i have no way to capture this issue. It does not show on the monitor. I tried my phone, but i think the phone’s frame rate is to low to show it.

2 Likes