Steamvr Compositor issue (SteamVR 1.15+):/

Guys need help , it gets me crazy :confused:
Today I’ve started experiencing weird issue with my steam vr , its mean all text in steamvr menus/home and text at some games is low resolutions. It’s never happend to me . Looks like steamvr compositor is rendering at low res. , like 1400x1700 , for example ACC (unreal engine game) gets blurry in menu but textures are sharp and high res.

Tried already :
1 ) deleting steamvr.vrsettings and editing new one ( 5 times)
My observation: when running steamvr app in steam than “gpuSpeedRenderTargetScale”: is changing itself constantly to values 0.19999998807907104,) ??!!
2) wfofix.exe tool from this forum
3) basically everything described here How To Make Your Pimax Image/Picture/Screen Clear/Crisp (Increase Clarity)
4) new Nvidia driver
5) reinstalling steamvr ( beta and non beta) and deleting all settings
6) checked fpsvr = no app bypasing steamvr resolution
7) no other tools installed which can change resolutions.

Loosing my mind , nothing helps. Need some clever suggestions.

2 Likes

SteamVR betas the last couple of days have been proclaimed candidates for a new stable release update - I guess maybe you just got such an update, and got a dose of the new ways of the world, that beta-users have been experiencing for a few weeks now…? :7

Something has been altered about how gpuSpeedRenderTargetScale is calculated, now taking matters of VRAM into account (apparently with some method or other added, for Pimax and others to have a hand in how it all works out)…

I get great compositor resolution with wide FOV mode, but reduced in the others, for some reason. :7

3 Likes

tried beta and non beta, its the same version since yesterday :confused:
What should I do?

1 Like

Take it as a man! :wink:.

1 Like

So we need older steamvr version but I don’t know where to grab it.

Not sure - /me opted to just live with it for now, until Somebody Else™ takes care of it. :stuck_out_tongue:

So Assetto Corsa renders its menus to a SteamVR overlay, then, instead of along with the rest of the game? I guess they have their reasons, if that is the case…

I don’t know how to roll back either, but maybe somebody else will chime in… I am sure mirage has a choice word or two in store. :wink:

I shall write them a very sterny worded letter! :stuck_out_tongue_winking_eye:

4 Likes

Some have downgraded steamvr version.

1 Like

buy 3090 so steamvr will estimate your performance accordingly :DDD, I got so many issues with steamvr yesterday & while was testing Odyssey+ got so many crashes lags & resolution issues, now I see that it can be the steam, however vive & index work flawlessly.

2 Likes

do you have any source with older versions ?

I only found that many have issue with it : https://steamcommunity.com/app/250820/discussions/3/2970649384343476674/

1 Like

Not off hand. Had looked into it before and unless it has changed iirc was a pain to downgrade.

@mirage335 may have a guide as he is often grumbling about steamvr updates.

1 Like

found workaround in other similar thread please change gpuSpeed to 4000 or 5000 in steamvr.settings file and that brings back compositor resolution

3 Likes

So this is solved now?

Also, this can happen if FFR is set.

1 Like

I would try what Yata posted above and report on it.

I guarantee that’s working in ACC , GpuSpeed 5000 gives me even sharper picture than before with the same fps ! Impreesive .

2 Likes

I tried to roll back SteamVR with the help of information from the Steam community, but I couldn’t find a valid manifest ID and couldn’t do it to my ability.

The solution I am now examining is at the following link.

1 Like

Hello,

We suggest you to downgrade the SteamVR version, or try to log a ticket with Steam, to get the older version and try to run the headset again.
If the issue still occur, please let us know.
We have forwarded this issue to the technician, and asked them to try on the latest SteamVR version, to check the matter.

Sincerely.

1 Like

I remember there was a SteamVRCompositor value inside of my steamvr.settings file at one point that was set to 200%. It was negatively impacting my VR performance at the time and removing the line helped.

If I can remember the exact line, we can add it and set it to 100% or 200% to see if that fixes the blurry overlays

1 Like

Update: I found this tool that looks like it would fix the compositor:

2 Likes

try make picture quality to 1.25

1 Like

Just read what I and others wrote - we have solution - GpuSpeed should be 5000 to get renderscale 1.5

2 Likes