SteamVR games not showing up in PE

@SweViver @arminelec

I had everything working fine with PE. I used the PE option to restart my HMD because it was having tracking issues. When the HMD restarted it crashed my computer. After my computer finished restarting I went back into PE and saw that the SteamVR game screen was empty. The Oculus and Viveport screens still showed their games.

I restarted my computer again and the SteamVr games still did not show up after restarting PE. I then reinstalled Pitool and PE. The SteamVR games still do not show up.

Any thoughts on what could have happened and what I need to do to get my SteamVR games to show again?


Thanks for reporting this issue and making a separate topic for it in the thread.

Have you also tried running Steam Client and Steam VR, without running PE, after you noticed that only Steam VR games are not displayed?
If not, please do so and check whether you can launch any Steam VR games from Steam or not.

  • If your game does not launch from Steam: then perhaps something could have gone wrong with your Steam or Steam VR installation.
  • If your game successfully launches from Steam: then simply quit Steam VR and Steam Client and run PE to see whether PE can show the VR games from Steam or not.

Sharing this result will help us narrow down the issue.



Thanks for the quick response. Yes I had ran a game direct from SteamVR after I saw that they were missing from PE. After running the game and going back to PE they still did not show.

I went ahead and fully uninstalled Pitool and PE. By fully I mean going in and also manually deleting all instances of pitool from the folders that the uninstaller doesn’t clean out. After reinstalilng everything this time I got the SteamVR games back in PE. Not sure what happened but a full reinstall of everything fixed it. The first time I had just reinstalled Pitool and PE without first uninstalling Pitool.

Thanks again for the response. You guys are doing a great job with the software!


Glad to hear you managed to make it work. If it happens again, feel free to reopen this thread and let us know.

And thank you so much for your compliments on our work. We are very happy to see all your enthusiasm and support :slight_smile:


@arminelec @SweViver

Hey guys, I don’t know if this will be a reproducible bug on your end or not but the problem happened to me again in the exact same way. I used the Pitool option to Reboot HMD and it again caused my computer to crash with a blue screen. When I got the computer rebooted and started up PE again, my SteamVr games had once again vanished. The only way to get them back was to once again completely uninstall Pitool by manually deleting the folders missed by the uninstallation program and then reinstalling. I first tried just uninstalling Pitool through control panel only and then reinstalling, but that still didn’t get my SteamVR games back. It seems that there is something in one of the folders that I have to manually delete that is getting corrupted.

I don’t know if this is something specific to my computer or not. I also noticed that this process seems to have deleted the launch options that I set for a couple of my SteamVR games. I had to add the launch options back in the SteamVr command box. I know now to avoid using the Reboot HMD option for now, but hopefully you’ll be able to figure what is going on if you are able to reproduce the problem on your end.

1 Like

That’s interesting! Thanks for sharing this new information.

Regarding why your machine/hardware/OS fails when you attempt to reboot the HMD, please contact Pimax support. I really hope they can figure out why this happens on your machine.

Regarding PE related matters, we will get back to you when we have something. As you mentioned, it is not a scenario we can reproduce on our machines at the moment. However, if anything goes wrong, it is likely that there is a corrupted file somewhere that PE cannot read from.

1 Like

same problem here, reinstalled twice now…no games.

  • all games start from steam
    PVR shows desktop etc…

@Bozothenutter…after you uninstall pitool using the program uninstall function in windows control panel, you then have to manually delete the pitool folders at all of the locations listed below. Then you should reinstall pitool and PE and everything should be back to normal. Pitool Install Locations

@SweViver @arminelec
My town had a power failure while i was running PE 84.
Offcourse HMD and everything shut down.

After we got back power in my town, i started PE to play a game, but the list of games in PE is empty now.

I still can see and start games from Pitools and SteamVR.
They are just missing in PE.

I´ve read that reinstalling PiTools and PE and all folders involved might fix the problem. But reinstalling and even set individual settings for the games again, should not be a solution.

Maybe you can add something like a brute force read-button or read the gamelist from backup file if it´s not readable no more or something like this.
That would be awesome!


Thank you for explaining the issue you’ve encountered. Indeed as you mentioned, reinstalling the app is not a good solution. We already have several failure protections and recovery cases PE covered that should automatically solve issues without the user ever needing to take extra steps.

Every time something goes wrong, we should have immediately look at the logs to find the root source of the issue. Would you please attach the PE log files?

They are located under:

C:\Users\<YourUserNameHere>\AppData\LocalLow\Pimax\Pimax VR Experience

They are named Player.log and Player-prev.log.

Just in case you do not see the AppData folder (common question), you can paste that address in Windows Explorer address bar, replace <YourUserNameHere> with your user name in WIndows and press Enter.


1 Like

It´s in your mailbox.



Thank you for submitting the logs. We have identified the issue. It will be covered by the background auto-import in the upcoming release.


Installing PE 85 restored my missing Games-List.
Nice Fix, thx.

1 Like