Update to latest Pitool failed to update my firmware, used alternate method

I havent used my 8KX for a while. Decided to give them a try again.

Updated to the latest pitool on the pimax site (299?). After the update, pitool started a automatic flashing of the headset by itself. Dont know what version it tried flashing with.
That update failed and now the headset is flashing blue-red-green.

I have hade this happening twice before after manual upates( Theres two threads from me about this). Both times I managed after some effort to fix it.

This time, reading my last thread the same procedure does nit work. Tried a few times.
I also found a support ingormation from pimax with the use if cmd prompt, I havent got that to work either.
I’ve already put 30 minutes with no joy, I found that in the device manager the “unit in DFU-mode” comes and goes under the USB Device, after being put into DFU mode.

Tips anyone?

I didnt had a FW flash with 273 on my 8kx, I flashed manually the latest.

The DFU mode doesnt seem stable, so the “STM Device in DFU mode” is visible for about one second, then dissappears for about 5 seconds and that goes on.
The DFU upgrading fails each time.

2 Likes

I saw that when I installed 272, but “DFU mode” never reappeared. If you are very quick, you can start DFU while the headset is in the initial “download firmware” state. It took me many tries, but eventually I succeeded.

I should point out that entering download mode is difficult for me (large fingers won’t let me press the buttons individually, I have to hold the volume buttons down with my thumb and shift to one-button-down by moving my thumb with a rocking motion.

I would really like to use PiTool to flash the firmware to any version. We know it can enter DFU mode and download the firmware, since it already does that to automatically update the firmware to a new version.

1 Like

But it is ”bricked” at the monent after the fsoled update so pitool doesnt recognize it at all.

The DFU update tool starts but get ibterupted in the process —-> upgrade failed. This happens every time.
Ive tried two other computers as well, same issue.
The headset worked fine before I updated the pitool.

@AAKEE .
Try this:
Shut down pitool and start taskmanager (ctr/alt/delete) shut down all pi-services.
Restart pitool and maybe the proces of updating starts again. Good luck .

2 Likes

That didnt work either.

I did find a thread with another way around( I do not find it now). I coied a few files and used another way top flash from DFU mode.

Now the tracking really sucks. I had luck before, the jitter was so small it could almost not be detected. Now the tracking is extremely bad. This sucks.

Try contacting support.


PimaxVR Support

Main Site
  • Self Help Database
  • Submit a Ticket
PimaxVR Forum Support

This group consists of PimaxVR Staff Specialists for assisting PimaxVR Consumers with resolving Ticket.

Please follow this Procedure before Requesting help.

  1. File a Support :tickets: At
  • PimaxVR
    You should receive a response within x Business days.
  1. If you have not received a response after x Business days or Support personnel is having difficulty understanding your request. Please Direct Message(PM) this group requesting assistance.
  • Please provide the following Information:
    Support Ticket # & Details of issue.

if your support issue is Tech related please explore:

  1. Use Docs in Left menu to explore 2 & 3.
  2. Pi-Guides & Troubleshooting. (#guides )
  3. Community Support - review Solved and post question if needed. (#vrcentral:helpme )
1 Like
  1. You wouldn’t happen to have a Thrustmaster steering wheel by chance? Their drivers are known to mess with Pimax’s firmware utility.

  2. Pitool 299 comes with a faulty firmware which they haven’t bothered to fix.

Here’s the real 299 firmware

2 Likes

Yes, I have a Thrustmaster wheel. I am aware of the issues with that but the old fix wouldnt work at all.
This time the first problem was the automatic Firmware update. As it started by itself I only could watch the way to the known failure.

Thank you very much for the ”fixed” 299, I will try that.
My 8KX works no with no flickering at 90hz but the tracking is all over the place (more movement than fit inside a jet fighter canopy :-/ )

2 Likes

Let us know how it goes. Good luck.

1 Like

After flashing to this Alternate 299 FW the very bad jumping around tracking dissappeared.

Byt the tracking is not rock solid so I guess I now have got the same jitter as other have. Before my jitter level was below the easy noticable and I wasnt concerned about it.

3 Likes

I had similar occur, and I simply unplugged the HMD from power outlet and then restarted the Pitool service. Then turned on headset, and it worked. I also rebooted the computer.

2 Likes

Lighthouse 2 or 1? .

SteamVR basestations 2.0.

I see in the old thread that 2.0 is problematic.
I had really good stabile tracking earlier( before summer, havent used the 8KX since until now).

I dont know if it is the software/firmware that changed this to the worse.