Vive Lighthouse troubles

Vive Lighthouse troubles
0

So i have recieved my 5K+, works ok, but the gyroscopic tracking sucks.
SO i have purchased Vive 1,0 lighthouse (just 1pc) but i´m unable to make it work, Pitool or SteamVR does not seems it whatever i tries, is there any trick to make it run?
Many thanks!

Whatever you tried so far?

Make sure lighthouse tracking is enabled in Pitool.
Make sure the channel on the lighthouse is set to B, placing it further away as well as turning the hmd to let more of the sensors get a glimpse of the beams the lighthouse sends out.

2 Likes

with 1 base channel A needs to be selected

4 Likes

From what ive read A/B is used if doing wired sync, B/C used when using wireless and just B when single.

3 Likes

I’m using channel A on my “seated”/single BS and B/C on my room-scale pair (different rooms), but I’ve read before that it doesn’t matter if You choose A or B for a single basestation.

3 Likes

No working either on A B or C mode:-(
LIghthouse seems functionall - Led pole, green diode and channel indicator is lighting, however it does not seems HMD at all:-(

1 Like

Is lighthouse tracking enabled in PiTool?

If yes, did You perform room setup in PiTool and then in SteamVR?

If yes, try moving the HMD close then far away then turn it around a few times in front of the lighthouse.

2 Likes

can you do a screenshot of pitool?

1 Like

Try restart your pc while light house is on. Then start PiTool.

2 Likes

You can look here for some general information.

More specifics about basestations under “Troubleshooting solutions > Basestation/lighthouse related”

4 Likes


Well now i tried again and it worked for a moment until i launched a game, then it collapsed again:(

3 Likes

Which version of PiTool are you running? Also, if you are switching to the latest PiTool (121 beta, 113? non-beta), then don’t forget to update your GPU drivers.

1 Like

I just recently set up a Vive v1 for my 8K. I had the LH at about 55 inches distant and at about a 30 degree angle off the left side of the HMD and slightly above. EDIT: LH is set to A. Using PiTools 121

I ran into two issues. At first the HMD would be recognized but the LH would not (grayed out). After rebooting the HMD a few times it would show the LH blue but not tracked. The Ready signal only showed erratically. When I received the Ready signal, the tracking would drop the second I tried to open any app.

First fix. I moved the USB cable of the 8K from a 3.0 powered hub to its own 3.1 port. This took care of the blue indicator coming on for the LH on startup. I still had to manage to get the LH to show Ready by moving the HMD. Once on apps would launch.

At this point the second issue arose. Once it was Ready it still lost tracking in games after 20 to 30 minutes of use. Second fix. I then moved the LH to almost directly in front of me (about 5 degrees off left) and higher at a distance of about 52 inches looking down at about a 30 degree angle. I do not lose tracking now.

Although the LH indicator in PiTools now starts as blue on startup I still have the issue of getting the Ready Indicator. What I do each time I start up is I hide the HMD under my desk for about 5 seconds and when I lift it above it says Ready. No idea why this works, sort of a reset. I do not lose the Ready indicator after this point and tracking in games lasts and is smooth.

I have no idea if this will help you but I thought I would share my experience.

EDIT: And I agree with your judgement of the HMD’s gyroscopic tracking.

2 Likes

I have last version of hmd fw, pitools and geforce drivers.
Well i have lighthouse on place of old oculus sensor - ca 90cm from headset, top right corner.
Did some experiments without help.
Also the hmd is in his own “VR ready” usb 3.0 port…

If I had to guess anything I would say the LH is too close and maybe should be higher. From other posts and videos I read that it should be at least 150cm away from HMD and looking down. Mine is about 130cm so there appears to be some wiggle room on distance.

3 Likes

BTW, this is my first experience with VR so I am not an expert is any way, shape, or form.

2 Likes

Mine is just above my monitor about 50 cm from my headset when playing.

Works fine but I always have to move away and turn the HMD around or cover it to get it tracked. As soon as it’s tracked I never loose tracking again unless I move it to where it can’t see the lighthouse (to far too either side).

5 Likes

Your screenshot shows hmd is not tracked. @neal_white_iii found 2m away worked for LH

3 Likes

Well you guys are probably right, it seems that problems are caused by position of LH - looks like it need to be higher and more far away…
I´ve experimented with photogrative tripod and after LOT OF trying i´ve found a place where it even let me run the assetto corsa and run a few laps:-)
Well tracking is WAY better then with gyro…
But it is very sensitive - when i make some “bad” head movement it looses tracking for a second immediatelly, i do not think it should work like that… Will experiment with position of LH some more and probably 3D print some LH wall holder or something like that (btw anybody knows what thread is in Vive LH - standart european M6 does not fit…).
EDIT: I´ve found - it is probably 1/4 inch:)
Thanks for help to all of you!

6 Likes