What is steamtours.exe

Hi,
While just using: Simple VR Video Player, Steamtours.exe starts working in the background, and possibly slowing down the videos.
It’s using resources, and it will stay on even after closing everything, until I kill it in task manager !

Anyone know what’s going on.

I’m on 92.

Well, it looks like it finally shuts down after a while.
What keeps using my cpu is: VR compositor, it’s staying at 25%… I’m killing it now.

I am not using simple vr player. Have you googled steamtours.exe?

Nothing clear comes up.

Hmmmm… Only i can find on it is some steam library related to workshop?

Maybe ask in steam community. Did notice a discussion on it using disk usage.

Dear friend
Simple VR Video Player is used with Steam VR,that means you must open Steam VR.This is the truth Simple VR used resources,you said you can not close it until you kill it in task manager! I think you can re-install Simple VR to try.

Rain its something to do with Steam.

Yes i think so.But we can try first.

I don’t think i will have time in the next few days but need to audit the taskmanager.

Launch Steamvr then run taskmanager & see if Steamtours.exe is running. The Steam discussion mentioning it did so without mentioning simple vr player. Only something about Workshop.

My guess would be it might be the Steam program that updates Steam Workshop items.

Will post in a min…

And

It appears to be linked to Source Engine 2 & has VR developement. SteamVR (i am guessing) & programs using the engine & workshop call Steamtours.exe

@anon33864247 & @anon23564932 are likely able to confirm better my guess. :wave::wink::+1::sparkles:

I Tested…

Started, steam vr… not there, started pimax… not there, pluged in HMD… steamtours starts !

No need for simple VR to play.

And when I shut down pimax and steam vr this time everything shut down fast.
So it is not a constant problem…sometimes it’s slow to shut down.

Last time This;

Stayed on and using 25% cpu until I killed it.

So the question remains what is steamtours and do we really need it ?

Hi, have you tested in our latest Piplay 1.2.75? Was it effective to reinstall Steam & SteamVR, please let me know ,thanks.

Hi

Can you look into steamtours.exe, seems to be loading once steamvr finds the headset.

Sure, but I also need more details from @thxo1138, please export logs to support@pimaxvr.com, we will analyze it and find the reason. Same as below:

Hello, after last uptade steamvr have home (steamtours.exe). This is alive if you run steamvr, and disable in preferences of steamvr. Home may seeing in HMD after starting steamvr. vr compositor - part of steam vr.
Sorry for bad language, i hope you understanding me)

2 Likes

Hi, thanks for your answer, but a little bit hard to understand.

First what is “home” (and see home in HMD) ?
And you mean it can be disabled ?
But what does it do ?
What happens if you disable it ?
Is it good, helpful, or just useless ?

To Support, I don’t think I have a special problem, I think it must be shared by many, I least that’s why I’m asking here, is for others to confirm they see the same things.

With SteamVr last update they introduced SteamVR Home.

Click on you desktop SteamVR window. In the options there is an option to disable SteamVR home.

SteamVR Home in the hmd looks like a living room in the hmd when SteamVR loaded instead of the grid void. It is very buggy atm.

OK I understand that, did not notice it yet in the HMD, (maybe not activated).

So steamtours is just a funny name they gave it to confuse people like me ?
Why not call it steamhome ? :slight_smile:

Thanks all !

It might be lol

It is in the SteamVR Beta. So if not running the beta will not be loading. :wink:

Plus its valve. I was more happy with the Millennium Falcon cockpit. :grin:

I just noticed the same with my Brand New 8K X, Started Project Cars 2 via Pitool but I see a blank screen in HMD, and when I close it and check GPU usage then I notice steamtours.exe using 75% of my RTX 3080 GPU, Can be the reason of Project Cars 2 showing blank in HMD?

Did you try this ?

“Click on you desktop SteamVR window. In the options there is an option to disable SteamVR home.”