Windows 11 and PiTools: what has your experience been like so far?

With the push for Windows 11 hitting mainstream, I’m curious how people’s experiences have been with it using Pitools?
If you have Windows 11, is your Pimax running smoothly? Have you noticed any differences? Which headset and which version of PiTools are you using?

I had to revert back as I have an apparent conflict with another piece of software, causing my explorer windows to crash to desktop. That was… interesting, but I never had a chance to get as far as re-installing PiTools.

Gee, I’ve missed major OS upgrades sooo much! .not.

2 Likes

Hi, I updated from W10 to W11 without any particular problems two months ago.
Apart from having disabled hardware acceleration because my pimax image jumps
Pitool 271 in use, same performance as w10
No bug
No regrets
may it last

4 Likes

No problems. With latest 274 pitool and with earlier versions. Its like win 10, just feels lighter. I like it.

1 Like

It’s been fine. Same is on Windows 10. I have some issues with Pitools but it’s not nothing to do with Windows 11, they just need to add better support for certain things.

Nah - there have been issues with Windows 11 and SteamVR.

Many patches later and still an issue.

I have the same problem with Win11
Image Jumps in DCS in Win11 so i downgrade my Win 11 to 10

I find Windows 11 seems more sensitive to VR GPU overloading. If you back off the SS res from where you find it stuttering, you are good to go.

Will check out the latest PiTool and see what that brings to the table.

1 Like

Disabled Hardware accelerated GPU Scheduling in Windows 11 - System - Display - Graphics - change default graphic settings.

Much better in VR now with major stutters gone. It is enabled by default in Windows 11

2 Likes

No issues with win 11 so far and Pimax Tools. Did a fresh install. Pain but worth it. Been running since win 11 release

1 Like

I wish I could say the same.
I’m using Pitool version 275, and W11 (21H2) freezes if I launch Pitool with headset connected.
If I start Pitool and then connect googles - it will work, but explorer will keep crashing.
Currently Nvidia 511.79 (latest), firmware m2001.

2 Likes

Man, you saved my life!

Just a small correction. The correct path is System/Display/Graphics/Default Graphics Settings, and then disable Hardware-accelerated GPU scheduling.

I’m using the Pimax 8KX to play Skyrim LE, with VorpX, and I was struggling with a very poor performance and a very bad image. Now, it works like a charm!

1 Like

Hi, did you find a solution for these system freezes? I have the same problem

I found 2 ports (z690-F motherboard, red ones, next to USB-C) which generate less problems, and reboot computer after starting it before launching Pitool.

1 Like