Yaw drift solution

I have discovered that if you sit facing north there is no yaw drift.

This should be a software problem, Pimax engineers should be able to solve it.
Please, let us know.

Install a compass on your cell phone, and check that you look north. Play any game in VR with the Pimax and you will not have drift

1 Like

Hi! Thank you for your suggestion. Please try to update to the latest FW, it can be better now.
But our engineer are solving this issue, and they tell me, it has a lot of reasons lead to drift
If you still have this problem, you can try it like this:Use your Pimax, and… draw a “8” in the sky.
Hahahaha, I don’t know why, it can be a little better.

You think its funny laughing about the drift problem? It makes pimax useless. You should stop selling this piece of shit and give everyone their money back

You have already got your money back, right?
A lot of customers think their Pimax is not bad and they do not wanna refund it. Why we need to stop selling this?
And if any wanna refund it, it is OK, we need to return the money back. That is our duty.
But you don’t have any power to let anybody refund it.
And if you are thinking any VR headset is better then Pimax, you can go to buy their headset, you can if you want.

1 Like

Yes, i have the last firmware and i have yaw drift. It is not a very strong drift, but I still have it. I also made the symbol of 8 and then let it rest on the table 10 seconds, that should calibrate the magnetometer. But still there is drift.

The only thing that completely eliminates drift is to play looking north. This is surely a software problem and can be solved with future updates. We are several people who have tried to play looking north and we have solved the problem of drifting. Please tell your engineers.


1 Like

Our engieers’ve known this issue, and they are making the solution to solve this problem.
I hope this issue will be solved in the future by the FW update.

1 Like

My 2 cts.
Put your pimax on a stable surface, facing the right direction for you and don’t touch it until you are ingame, not in the menu game.
So far it seems to have solved my issue.
When i play to pcars i wait until i’m on the track to put the pimax on my head. It works 8/10.

Even if I turn to the north and start with stillness, my PIMAX will start to drift.
If there is no solution, I would like to completely eliminate it.
I have a TrackIR for 6 DOF and I do not mind even HMD without a gyro.
Please add the option to set the parameter transmitted by the gyro to (0, 0, 0).

1 Like

I Still having a lot of drift even with the last beta firmware + piplay.

Please give us update on yaw drift problem and also post a changelog for the firmware changes to each version of firmware.

I totally agree with this.
I just tested Pimax V2 and witnessed yaw drift.
In Korea, the recently sold product is called Pimax V2.
The Pimax V2 is advertised as a product with a blue light lens removed, unlike the one I use.
A few days ago I claimed to have solved the drift, but I tested the latest V2 and decided to withdraw it.
Please confirm that Pimax is experiencing a drift problem and correct it.
I think it only appears in V2.

I confirm. I still having yaw drift. Sometimes is worst than others but it remains. I think that when the PC is stressed out, the yaw drift is more noticeable like when I use greater steam supersampling values than default, for example 1.5. But I’m not sure about this

es muy aleatoria la cosa, algunos hacemos el tema de los ochos como en OSVR, yo casi no tengo deriba y desde esa actualizacion de firmware menos…

Yaw drift here too… It drifts within 2-5 min by around 5-15 degrees. Its very hard to play anything with that kind of drif. Is there anything we can do ? I have trackIR and Vive. If ounly I could use one of these to assist tracking of Pixma it would’ve helped a lot.

While i haven’t used it. Edtracker might be a solution as it can combine sources for position.

I have it. Any idea how to path it in to games ?

I am not sure. Maybe try sesrching forums using “edtracker” as keyword. I know i have seen it discussed in the forums.

I found a solution. When I power on HDM I let it on table for about 2 minutes and after that I start Steam VR. (PiTool is started at windows start). Than it’s OK with no drift. Sometimes it has to do “room setup” but most of times when I do it this way, there is no drift.Try it please and let me know.

1 Like