Your post in “Pimax 5k plus being recognised as Pimax 8k in PiTools”

Hi Pimax

I have had a support tickets #7049 open for over a week.
I’ve updated pi tools to .263 and also the latest firmware on the headset to .268 using the dfu.exe within the pimax folder.

However for some strange bizarre reason PITools recognises my P2 203 5k plus as a 8k. Occasionally it remembers it’s itself (as a 5k plus) and I’m able to use it but when I restart my machine it reloads back as an 8k plus and is unusable.

Can someone pls help me as this is incredibly frustrating and I’ve tried almost everything. This is putting me off upgrading to the 8k plus.

@PimaxQuorra @Miracle

1 Like

268 was only for the 8K or 8KX if I recall. You’ll want to downgrade to 264 or other compatible firmware.

1 Like

Try this…

https://community.openmr.ai/t/pimax-5k-plus-being-recognised-as-pimax-8k-in-pitools/30912/4?u=neal_white_iii

2 Likes

So the first time I used .263 from above it then recognised the headset correctly. However I could now see horizontal lines across the right lens whilst playing asseto Corsa. I then decided to upgrade to .264 and then it’s returned to being recognised as 8k. I then try to flash the firmware back to .255 and it’s still saying 8k even though this version of the firmware is only for 5k plus.

@PimaxQuorra @Miracle

I think it’s time for you to submit a ticket to Support.

https://support.pimax.com/en/support/tickets/new

Yeah had one open since last Friday :frowning: taking forever been 9 days. #7049

@PimaxQuorra @Miracle

1 Like

Hello,

We have forwarded the ticket to the technician, they shall contact with you shortly, and will resolve the firmware/pitool issue for you.

Sincerely.